From: "Pawel Zalewski (The Capable Hub)" <[email protected]>
Use a named initializer for the acpi_device_id fields which makes the code more readable and consistent with how lists are initialized in the rest of the kernel code base. Also drop explicitly setting fields to 0 where it is redundant. Signed-off-by: Pawel Zalewski (The Capable Hub) <[email protected]> --- drivers/char/hw_random/hisi-trng-v2.c | 2 +- drivers/char/hw_random/xgene-rng.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/char/hw_random/hisi-trng-v2.c b/drivers/char/hw_random/hisi-trng-v2.c index 6584ed051e09..9e0ecea56ad6 100644 --- a/drivers/char/hw_random/hisi-trng-v2.c +++ b/drivers/char/hw_random/hisi-trng-v2.c @@ -77,7 +77,7 @@ static int hisi_trng_probe(struct platform_device *pdev) } static const struct acpi_device_id hisi_trng_acpi_match[] = { - { "HISI02B3", 0 }, + { .id = "HISI02B3" }, { } }; MODULE_DEVICE_TABLE(acpi, hisi_trng_acpi_match); diff --git a/drivers/char/hw_random/xgene-rng.c b/drivers/char/hw_random/xgene-rng.c index 1f4b95341c2e..222db3fb275b 100644 --- a/drivers/char/hw_random/xgene-rng.c +++ b/drivers/char/hw_random/xgene-rng.c @@ -296,7 +296,7 @@ static int xgene_rng_init(struct hwrng *rng) #ifdef CONFIG_ACPI static const struct acpi_device_id xgene_rng_acpi_match[] = { - { "APMC0D18", }, + { .id = "APMC0D18" }, { } }; MODULE_DEVICE_TABLE(acpi, xgene_rng_acpi_match); -- 2.55.0

