On 14/8/26 00:26, [email protected] wrote: >> In the next commit, percpu_array map will add map_direct_value_addr >> support. >> IOW, it will add a map_type check in the iff condition of the >> bpf_map_direct_read() code block, which will reduce the code block >> readability. >> Hence, factor out check_map_mem_read helper to improve the readability, >> and the maintainability for the percpu_array map case. > > This isn't a bug, but did 'the iff condition' mean 'the if condition' > guarding the bpf_map_direct_read() call? And since this looks like a pure > code motion, would it be worth adding a 'No functional change intended.' > line so reviewers know what to expect?
'No functional change intended.' is worth in the commit msg. Thanks, Leon

