Hadn't used my Hauppauge HDPVR for a while, decided to check status of

Doesn't seem to be working now.  Everything initializes okay (afaict),
but it doesn't seem to want to start streaming.

In the past, a command like this has worked for playback:

vlc v4l2c:///dev/video2 \
    --v4l2-chroma=H264 \
    --v4l2-width=1920 \

Running that with -vvv, I get output that includes words to the effect of:


Running the module with buffer debug on shows the following from dmesg:


I'm probably in over my head, but if I could hazard a guess, I'd say
there's something awry with the frame rate it is trying to set.  Video
input is off a DirecTV box component input using the SPDIF input.

Also tried mplayer, and I sometimes get a video feed (but it tries to
use hwac3 for my audio, wish isn't going to work with my setup).  In
this case, streaming seems to get started (according to buffer debug),
but output is either nonexistent, or it will play video for a few
seconds then exit.

And from dmesg in that case: https://termbin.com/pwsp

If someone could point me in the right direction, I can try to fix this
-- or if someone has a solution, I'd very much appreciate the help.

Thank you,


Reply via email to