Hi Scott,

On 9/2/19 3:02 AM, Scott Doty wrote:
> Hello,
> Hadn't used my Hauppauge HDPVR for a while, decided to check status of
> driver.
> Doesn't seem to be working now.  Everything initializes okay (afaict),
> but it doesn't seem to want to start streaming.
> In the past, a command like this has worked for playback:
> vlc v4l2c:///dev/video2 \
>     --v4l2-chroma=H264 \
>     --v4l2-width=1920 \
>     --v4l2-height=1080
> Running that with -vvv, I get output that includes words to the effect of:
>    https://termbin.com/re3q
> Running the module with buffer debug on shows the following from dmesg:
>    https://termbin.com/u39v
> I'm probably in over my head, but if I could hazard a guess, I'd say
> there's something awry with the frame rate it is trying to set.  Video
> input is off a DirecTV box component input using the SPDIF input.
> Also tried mplayer, and I sometimes get a video feed (but it tries to
> use hwac3 for my audio, wish isn't going to work with my setup).  In
> this case, streaming seems to get started (according to buffer debug),
> but output is either nonexistent, or it will play video for a few
> seconds then exit.
> And from dmesg in that case: https://termbin.com/pwsp
> If someone could point me in the right direction, I can try to fix this
> -- or if someone has a solution, I'd very much appreciate the help.
The only non-trivial change in hdpvr in 5.3 is this commit:

commit 6bc5a4a1927556ff9adce1aa95ea408c95453225
Author: Hans Verkuil <hverk...@xs4all.nl>
Date:   Thu Jun 20 07:43:41 2019 -0400

    media: hdpvr: fix locking and a missing msleep

Try reverting it and see if it makes a difference.

Also test with 'v4l2-ctl -d /dev/videoX --stream-mmap' and see if it
keeps streaming buffers or if it also stalls.



Reply via email to