On Mon, Nov 19, 2012 at 02:50:49AM +0000, Huang Changming-R66093 wrote:
[...]
> > --- a/drivers/mmc/host/sdhci-of-esdhc.c
> > +++ b/drivers/mmc/host/sdhci-of-esdhc.c
> > @@ -179,6 +179,28 @@ static void esdhc_of_platform_init(struct sdhci_host
> > *host)
> > host->quirks2 |= SDHCI_QUIRK2_HOST_NO_CMD23;
> > }
> >
> > +/* Return: none zero - the card is presetn; 0 - card is absent */
> > +static int esdhc_of_get_cd(struct sdhci_host *host)
> > +{
> > + int present;
> > +
> > + if (host->flags & SDHCI_DEVICE_DEAD)
> > + present = 0;
return 0;
> > + else {
then you don't need the 'else', which reduces indentation level.
> > + int sysctl = sdhci_be32bs_readl(host, SDHCI_CLOCK_CONTROL);
empty line is needed here.
> > + /* Enable the controller clock to update the present state */
> > + sdhci_be32bs_writel(host, sysctl | SDHCI_CLOCK_INT_EN,
> > + SDHCI_CLOCK_CONTROL);
empty line for better readability.
> > + /* Detect the card present or absent */
> > + present = sdhci_be32bs_readl(host, SDHCI_PRESENT_STATE);
> > + present &= (SDHCI_CARD_PRESENT | SDHCI_CARD_CDPL);
ditto here.
> > + /* Resve the previous to System control register */
> > + sdhci_be32bs_writel(host, sysctl, SDHCI_CLOCK_CONTROL);
> > + }
> > +
> > + return present;
> > +}
> > +
> > static struct sdhci_ops sdhci_esdhc_ops = {
> > .read_l = esdhc_readl,
> > .read_w = esdhc_readw,
> > @@ -191,6 +213,7 @@ static struct sdhci_ops sdhci_esdhc_ops = {
> > .get_max_clock = esdhc_of_get_max_clock,
> > .get_min_clock = esdhc_of_get_min_clock,
> > .platform_init = esdhc_of_platform_init,
> > + .get_cd = esdhc_of_get_cd,
> > #ifdef CONFIG_PM
> > .platform_suspend = esdhc_of_suspend,
> > .platform_resume = esdhc_of_resume,
> > --
> > 1.7.9.5
Otherwise, it looks good to me.
Reviewed-by: Anton Vorontsov <[email protected]>
--
To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html