The revert appears in the 4.2.4 log as well, so it happened before 4.2 was 
released. From what I can see, that ti-st directory hasn't changed between 
4.2.4 and the 4.3.

-----Original Message-----
From: Grygorii Strashko [] 
Sent: Monday, October 26, 2015 9:55 AM
To: Adam Ford <>; '' 
<>; '' <>; 
'' <>
Cc: 'Tony Lindgren' <>; '' 
<>; Sekhar Nori <>
Subject: Re: Question about TI Shared Transport

On 10/26/2015 03:58 PM, Adam Ford wrote:
> Gigi,
> I am working on modifying the DTS and DTSI files for the LogicPD Torpedo 
> which Tony added in Kernel 4.2
> There was a flurry of activity earlier this year regarding device tree 
> bindings for the shared transport and using the Bluetooth with it as seen 
> here:
> I was able to get the Logic PD device to work with Bluetooth and the Shared 
> Transport using the instructions found 
> When I attempted to submit patches for the btwilink, the check script noted 
> that the documentation for btwlink and shared transport bindings were 
> missing.  It seems like there might be a new way to attach the BTWILINK to 
> the UART, but I wasn't sure if there was a better solution available yet.
> I also noticed that using the shared transport mechanism in 4.2.x worked, but 
> trying the same method in 4.3 resulted in a segmentation fault.  Does anyone 
> have any updated instructions for the proper way to use the BTWILINK?

It is not worked because OF support was reverted:
c0bd1b9 Revert "ti-st: add device tree support"

To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to
More majordomo info at

Reply via email to