On T, 2020-06-02 at 22:33 -0500, Matt Krenik wrote:
> Hello Arti,
> 
> Thanks so much for your detailed reply. I tried the first suggestion
> of just zeroing out the initial SPL loader. Its not clear if I
> accessed the correct location, because there is no /dev/mmcblk0.
> Instead I tried a few different options, including: '/dev/block/by-
> name/boot'  '/dev/block/by-name/bootloader' and '/dev/block/nanda'.
> In each of the cases, I believe the device is getting past the
> initial SPL loader, but is getting stuck on the main bootloader. I'll
> keep trying to find out what memory device could store the initial
> SPL loader. 

Its possible that SPL is stored in raw NAND or in a SPI Flash chip. You
probably have to hook up serial console to figure that out.


> I did notice that when I probe 'lsusb' when the device is first
> starting, the device appears in flash mode for a small window of time
> before loading the bootloader. I have been unable to figure out a way
> to take advantage of this to flash the device (I tried starting the
> sunxi-livesuite gui), since it proceeds to the bootloader. This was
> surprising to me according to the documentation on the Sunxi linux
> wiki. Its clear that I'm working with some custom/vendor firmware
> that might differ from what is standard.
> 
> Again, thanks for your help. It seems that I'm on my own since I'm
> working with hardware that differs from what this community supports.
> But if you have any tips on what I can investigate, I would find it
> extremely helpful. 
> 
> Best,
> Matt


-- 
You received this message because you are subscribed to the Google Groups 
"linux-sunxi" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to linux-sunxi+unsubscr...@googlegroups.com.
To view this discussion on the web, visit 
https://groups.google.com/d/msgid/linux-sunxi/5281ce053fc8cb663a862c8130a8107abbcf0c44.camel%40gmail.com.

Reply via email to