This is v9 of guest_memfd in-place conversion support. Please find the
motivation for this series from v8 and before.

Here are the changes from v8->v9:

+ Ordering changes: Reverted to the v7 and
  github/sean-jc/linux/x86/gmem_inplace ordering.
     + Xiaoyao/Sean, hope this works better.
+ For Sean (since github/sean-jc/linux/x86/gmem_inplace was never on-list)
    + Extracted these patches out of your "KVM: guest_memfd: Wire up
      core per-gmem attribute interfaces" to have the wiring up patch
      focus on wiring up.
            + "KVM: guest_memfd: Introduce function to check GFN
          private/shared status"
        + "guest_memfd: Introduce function to check GFN private/shared
          status"
    + Moved the patches that allow conversions for TDX and SNP after
      the TDX and SNP changes to make source addr optional, so that
      once conversions can be used with TDX they will work.
    + Added to the description of "KVM: Let userspace disable per-VM
      mem attributes, enable per-gmem attributes" to explain the
      components of the change better.
+ Centralized interpretation of a maple tree entry - the part where
  guest_memfd will default to the initial shared/private state if
  entry is NULL - into kvm_gmem_interpret_entry().
+ "KVM: selftests: Add support for mmap() on guest_memfd in core library"
    + For guest_memfd, always mmap with MAP_SHARED. guest_memfd only
      supports MAP_SHARED.
        + Dropped "KVM: selftests: Check fd/flags provided to mmap() when
      setting up memslot" [1], since it was meant to check that when a
      guest_memfd is used as region->fd, the flag provided to mmap()
      will include MAP_SHARED.
+ "KVM: guest_memfd: Wire up core private/shared attribute interfaces"
    + Renamed kvm_gmem_range_is_private() to kvm_range_is_private()
      since this function checks both VM and guest_memfd attributes.
+ Dropped "Use actual size for invalidation in kvm_gmem_release()"
  since now the invalidation logic doesn't determine filter based on
  range. Only zap pages not already in the desired state. [Suzuki]
+ To address Vlastimil and David's comments [2] on freezing refcounts,
  in this patch series we're checking for safe refcounts to ensure
  that there are no other users of the memory. For this series, we can
  tolerate speculative bump+release of the refcounts, since those
  don't access memory. I'll definitely re-look refcount freezing when
  we get to the point that we need to restructure (split/merge) huge
  pages. Thanks!
+ Addressed the other comments from v8

Tested with both CONFIG_KVM_VM_MEMORY_ATTRIBUTES enabled and disabled:

+ tools/testing/selftests/kvm/guest_memfd_test.c
+ tools/testing/selftests/kvm/pre_fault_memory_test.c
+ tools/testing/selftests/kvm/x86/guest_memfd_conversions_test.c
+ tools/testing/selftests/kvm/x86/private_mem_conversions_test.c
+ tools/testing/selftests/kvm/x86/private_mem_kvm_exits_test.c

This series is based on kvm-x86/next, and here's the tree for your convenience:

https://github.com/googleprodkernel/linux-cc/commits/guest_memfd-inplace-conversion-v9

I tested v9 with CoCo selftests on top of the branch above:

https://github.com/googleprodkernel/linux-cc/commits/guest_memfd-inplace-conversion-coco-selftests-v9

Older series:

v8: 
https://lore.kernel.org/r/[email protected]
v7: 
https://lore.kernel.org/r/[email protected]
v6: 
https://lore.kernel.org/r/[email protected]
RFC v5: 
https://lore.kernel.org/r/[email protected]
RFC v4: 
https://lore.kernel.org/all/[email protected]/T/
RFC v3: 
https://lore.kernel.org/r/[email protected]/T/
RFC v2: 
https://lore.kernel.org/all/[email protected]/T/
RFC v1: 
https://lore.kernel.org/all/[email protected]/T/

Previous versions of this feature, part of other series, are available at:

+ 
https://lore.kernel.org/all/bd163de3118b626d1005aa88e71ef2fb72f0be0f.1726009989.git.ackerley...@google.com/
+ https://lore.kernel.org/all/[email protected]/
+ 
https://lore.kernel.org/all/b784326e9ccae6a08388f1bf39db70a2204bdc51.1747264138.git.ackerley...@google.com/

[1] 
https://lore.kernel.org/all/[email protected]/
[2] https://lore.kernel.org/all/[email protected]/

Signed-off-by: Ackerley Tng <[email protected]>
---
Ackerley Tng (23):
      KVM: guest_memfd: Introduce function to check GFN private/shared status
      KVM: guest_memfd: Filter both shared and private when invalidating
      KVM: guest_memfd: Add base support for KVM_SET_MEMORY_ATTRIBUTES2
      KVM: guest_memfd: Ensure pages are not in use before conversion
      KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
      KVM: guest_memfd: Return early if range already has requested attributes
      mm: swap: Introduce lru_add_drain_progressive()
      KVM: guest_memfd: Handle lru_add fbatch refcounts during conversion 
safety check
      KVM: guest_memfd: Zero page while getting pfn
      KVM: TDX: Make source page optional for KVM_TDX_INIT_MEM_REGION
      KVM: Let userspace disable per-VM mem attributes, enable per-gmem 
attributes
      KVM: selftests: Test basic single-page conversion flow
      KVM: selftests: Test conversion flow when INIT_SHARED
      KVM: selftests: Test conversion precision in guest_memfd
      KVM: selftests: Test conversion before allocation
      KVM: selftests: Convert with allocated folios in different layouts
      KVM: selftests: Test that truncation does not change shared/private status
      KVM: selftests: Add helpers to pin pages with CONFIG_GUP_TEST
      KVM: selftests: Test conversion with elevated page refcount
      KVM: selftests: Reset shared memory after hole-punching
      KVM: selftests: Provide function to look up guest_memfd details from gpa
      KVM: selftests: Make TEST_EXPECT_SIGBUS thread-safe
      KVM: selftests: Update private_mem_conversions_test to mmap() guest_memfd

Michael Roth (1):
      KVM: SEV: Make 'uaddr' parameter optional for KVM_SEV_SNP_LAUNCH_UPDATE

Sean Christopherson (17):
      KVM: guest_memfd: Introduce per-gmem attributes, use to guard user 
mappings
      KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
      KVM: Enumerate support for PRIVATE memory iff kvm_arch_has_private_mem is 
defined
      KVM: Rename memory attribute APIs to prepare for in-place gmem conversion
      KVM: Provide generic interface for checking memory private/shared status
      KVM: guest_memfd: Wire up core private/shared attribute interfaces
      KVM: Consolidate private memory and guest_memfd ifdeffery in kvm_host.h
      KVM: Move KVM_VM_MEMORY_ATTRIBUTES config definition to x86
      KVM: guest_memfd: Enable INIT_SHARED on guest_memfd for x86 Coco VMs
      KVM: selftests: Create gmem fd before "regular" fd when adding memslot
      KVM: selftests: Rename guest_memfd{,_offset} to gmem_{fd,offset}
      KVM: selftests: Add support for mmap() on guest_memfd in core library
      KVM: selftests: Add selftests global for guest memory attributes 
capability
      KVM: selftests: Add helpers for calling ioctls on guest_memfd
      KVM: selftests: Test that shared/private status is consistent across 
processes
      KVM: selftests: Provide common function to set memory attributes
      KVM: selftests: Update private memory exits test to work with per-gmem 
attributes

 Documentation/virt/kvm/api.rst                     |  78 +++-
 .../virt/kvm/x86/amd-memory-encryption.rst         |  14 +-
 Documentation/virt/kvm/x86/intel-tdx.rst           |   4 +
 arch/x86/include/asm/kvm-x86-ops.h                 |   2 +-
 arch/x86/include/asm/kvm_host.h                    |   6 +-
 arch/x86/kvm/Kconfig                               |  15 +-
 arch/x86/kvm/mmu/mmu.c                             |  16 +-
 arch/x86/kvm/svm/sev.c                             |  11 +-
 arch/x86/kvm/vmx/tdx.c                             |   8 +-
 arch/x86/kvm/x86.c                                 |  20 +-
 include/linux/kvm_host.h                           |  76 +--
 include/linux/swap.h                               |   2 +
 include/trace/events/kvm.h                         |   6 +-
 include/uapi/linux/kvm.h                           |  16 +
 mm/gup.c                                           |  19 +-
 mm/swap.c                                          |  17 +
 tools/testing/selftests/kvm/Makefile.kvm           |   1 +
 tools/testing/selftests/kvm/include/kvm_util.h     | 139 +++++-
 tools/testing/selftests/kvm/include/test_util.h    |  34 +-
 tools/testing/selftests/kvm/lib/kvm_util.c         | 164 ++++---
 tools/testing/selftests/kvm/lib/test_util.c        |   7 -
 .../kvm/x86/guest_memfd_conversions_test.c         | 509 +++++++++++++++++++++
 .../kvm/x86/private_mem_conversions_test.c         |  53 ++-
 .../selftests/kvm/x86/private_mem_kvm_exits_test.c |  36 +-
 virt/kvm/Kconfig                                   |   3 -
 virt/kvm/guest_memfd.c                             | 465 +++++++++++++++++--
 virt/kvm/kvm_main.c                                |  92 ++--
 27 files changed, 1551 insertions(+), 262 deletions(-)
---
base-commit: 3c7d7f908d574277a845423ec32250a8d8df44c8
change-id: 20260225-gmem-inplace-conversion-bd0dbd39753a

Best regards,
--
Ackerley Tng <[email protected]>



Reply via email to