This short series unifies minimum page calculation for ring buffers and
fix a small issue with the number of pages calculation for trace
remotes.
v2:
- Add a helper in "Account for ring buffer page header in size
calculation" (Steven)
- Split the nr_pages overflow handling into its own patch (Steven)
- Rename the helpers into __calc_nr_pages_ring_buffer_desc() and
rb_calculate_nr_pages() (Steven)
- Use RING_BUFFER_MIN_NR_PAGES in trace_rb_cpu_prepare() (Sashiko)
v1: https://lore.kernel.org/all/[email protected]
Vincent Donnefort (3):
tracing/remotes: Account for ring buffer page header in size
calculation
tracing/remotes: Catch nr_page_va overflow in ring_buffer_desc sizing
ring-buffer: Unify ring buffer minimum page calculations
include/linux/ring_buffer.h | 26 +++++++++++++++++++++++--
kernel/trace/ring_buffer.c | 32 +++++++++++++------------------
kernel/trace/simple_ring_buffer.c | 4 ++--
kernel/trace/trace_remote.c | 6 +++++-
4 files changed, 44 insertions(+), 24 deletions(-)
base-commit: df2908090cda368b01ff43709f51890076c56157
--
2.55.0.1007.g17ff1f9808-goog