linux-trace-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
Re: [PATCH 27/39] mm: rename is_vm_hugetlb_page() to vma_is_hugetlb()
sashiko-bot
Re: [PATCH 27/39] mm: rename is_vm_hugetlb_page() to vma_is_hugetlb()
Marc Zyngier
Re: [PATCH 27/39] mm: rename is_vm_hugetlb_page() to vma_is_hugetlb()
Anup Patel
[PATCH 33/39] mm: eliminate VMA_SPECIAL_FLAGS usage when hugetlb explicitly tested
Lorenzo Stoakes (ARM)
Re: [PATCH 33/39] mm: eliminate VMA_SPECIAL_FLAGS usage when hugetlb explicitly tested
sashiko-bot
[PATCH 18/39] fbdev: defio: assert FBINFO_VIRTFB, drop VM_IO, add VM_MIXEDMAP
Lorenzo Stoakes (ARM)
Re: [PATCH 18/39] fbdev: defio: assert FBINFO_VIRTFB, drop VM_IO, add VM_MIXEDMAP
sashiko-bot
Re: [PATCH 18/39] fbdev: defio: assert FBINFO_VIRTFB, drop VM_IO, add VM_MIXEDMAP
Thomas Zimmermann
[PATCH 07/39] mm: add mmap action for discontiguous kernel page mapping
Lorenzo Stoakes (ARM)
Re: [PATCH 07/39] mm: add mmap action for discontiguous kernel page mapping
sashiko-bot
[PATCH 16/39] mm/vma: add and use vma_[flags]_is_fixed_mapping
Lorenzo Stoakes (ARM)
Re: [PATCH 16/39] mm/vma: add and use vma_[flags]_is_fixed_mapping
sashiko-bot
[PATCH] bootconfig: merge _xbc_exit() into xbc_exit()
Sang-Heon Jeon
Re: [PATCH] bootconfig: merge _xbc_exit() into xbc_exit()
Google
[PATCH] ring-buffer: Add a MAINTAINERS category specific for the tracing ring-buffer
Steven Rostedt
Re: [PATCH] ring-buffer: Add a MAINTAINERS category specific for the tracing ring-buffer
Steven Rostedt
Re: [PATCH] ring-buffer: Add a MAINTAINERS category specific for the tracing ring-buffer
Vincent Donnefort
Re: [PATCH] ring-buffer: Add a MAINTAINERS category specific for the tracing ring-buffer
Steven Rostedt
Re: [PATCH] ring-buffer: Add a MAINTAINERS category specific for the tracing ring-buffer
Google
Re: [PATCH] ring-buffer: Add a MAINTAINERS category specific for the tracing ring-buffer
Vincent Donnefort
Re: [PATCH] ring-buffer: Add a MAINTAINERS category specific for the tracing ring-buffer
Steven Rostedt
[PATCH v2 0/3] tracing: Rename to "capacity"
Vincent Donnefort
[PATCH v2 2/3] tracing: Rename trace_array::entries to capacity
Vincent Donnefort
[PATCH v2 1/3] ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity()
Vincent Donnefort
[PATCH v2 3/3] tracing: Rename tracing_entries_fops to tracing_capacity_fops
Vincent Donnefort
Re: [syzbot] [trace?] WARNING in trace_rb_cpu_prepare
syzbot
[PATCH v2 0/7] tracing: Parse filter from boot event string
Thomas Weißschuh
[PATCH v2 3/7] tracing: Stop modifying the input buffer in ftrace_set_clr_event()
Thomas Weißschuh
[PATCH v2 1/7] tracing: Restore :mod: trailer after parsing in ftrace_set_clr_event()
Thomas Weißschuh
[PATCH v2 4/7] tracing: Split the event string parsing logic into a dedicated function
Thomas Weißschuh
[PATCH v2 6/7] tracing: Add a filter argument to __ftrace_set_clr_event()
Thomas Weißschuh
[PATCH v2 2/7] tracing: Remove duplicate declaration of ftrace_set_clr_event()
Thomas Weißschuh
[PATCH v2 7/7] tracing: Parse filter from boot event string
Thomas Weißschuh
Re: [PATCH v2 7/7] tracing: Parse filter from boot event string
sashiko-bot
[PATCH v2 5/7] tracing: Add a test for ftrace_parse_event_string()
Thomas Weißschuh
Re: [PATCH v3] tracing: Export live module tracepoint strings in printk_formats
Cao Ruichuang
[PATCH v3 00/14] Remove PG_private by using page/folio->private checks instead
Zi Yan
[PATCH v3 09/14] mm/page-flags: check page/folio->private instead of PG_private
Zi Yan
Re: [PATCH v3 09/14] mm/page-flags: check page/folio->private instead of PG_private
David Hildenbrand (Arm)
Re: [PATCH v3 09/14] mm/page-flags: check page/folio->private instead of PG_private
Zi Yan
[PATCH v3 14/14] mm/page-flags: remove PG_private
Zi Yan
Re: [PATCH v3 14/14] mm/page-flags: remove PG_private
David Hildenbrand (Arm)
Re: [PATCH v3 14/14] mm/page-flags: remove PG_private
Zi Yan
Re: [PATCH v3 14/14] mm/page-flags: remove PG_private
David Hildenbrand (Arm)
Re: [PATCH v3 14/14] mm/page-flags: remove PG_private
Zi Yan
[PATCH v3 10/14] mm/page-flags: introduce folio_test_fs_private()
Zi Yan
Re: [PATCH v3 10/14] mm/page-flags: introduce folio_test_fs_private()
David Hildenbrand (Arm)
Re: [PATCH v3 10/14] mm/page-flags: introduce folio_test_fs_private()
Zi Yan
Re: [f2fs-dev] [PATCH v3 00/14] Remove PG_private by using page/folio->private checks instead
patchwork-bot+f2fs
[PATCH v1 0/2] ring-buffer: Fix and unify size and page calculations
Vincent Donnefort
[PATCH v1 2/2] ring-buffer: Unify ring buffer minimum page calculations
Vincent Donnefort
Re: [PATCH v1 2/2] ring-buffer: Unify ring buffer minimum page calculations
sashiko-bot
Re: [PATCH v1 2/2] ring-buffer: Unify ring buffer minimum page calculations
Steven Rostedt
[PATCH v1 1/2] tracing/remotes: Account for ring buffer page header in size calculation
Vincent Donnefort
Re: [PATCH v1 1/2] tracing/remotes: Account for ring buffer page header in size calculation
sashiko-bot
Re: [PATCH v1 1/2] tracing/remotes: Account for ring buffer page header in size calculation
Steven Rostedt
Re: [PATCH v1 1/2] tracing/remotes: Account for ring buffer page header in size calculation
Vincent Donnefort
[PATCH v2 5.15/6.1/6.6 0/2] tracing/mmiotrace: Add NULL check for mmio_trace_array in logging functions
Alexander Martyniuk
[PATCH v2 5.15/6.1/6.6 2/2] tracing/mmiotrace: Add NULL check for mmio_trace_array in logging functions
Alexander Martyniuk
[PATCH v2 5.15/6.1/6.6 1/2] tracing/mmiotrace: Remove reference to unused per CPU data pointer
Alexander Martyniuk
Re: [PATCH v2 5.15/6.1/6.6 0/2] tracing/mmiotrace: Add NULL check for mmio_trace_array in logging functions
Sasha Levin
[PATCH 0/2] tracing: fix two histogram stacktrace keys that corrupt memory
Donggeun Yoo
[PATCH 1/2] tracing: Fix memory corruption from the stacktrace modifier
Donggeun Yoo
[PATCH 2/2] tracing: Fix memory corruption from a "STACKTRACE" histogram key
Donggeun Yoo
[PATCH 0/2] tracing: hist: two named trigger error paths that free a published trigger
Donggeun Yoo
[PATCH 1/2] tracing: hist: take the reference before publishing the named trigger
Donggeun Yoo
Re: [PATCH 1/2] tracing: hist: take the reference before publishing the named trigger
sashiko-bot
Re: [PATCH 1/2] tracing: hist: take the reference before publishing the named trigger
Donggeun Yoo
Re: [PATCH 1/2] tracing: hist: take the reference before publishing the named trigger
Tom Zanussi
[PATCH 2/2] tracing: hist: undo the registration when enabling the trigger fails
Donggeun Yoo
Re: [PATCH 2/2] tracing: hist: undo the registration when enabling the trigger fails
sashiko-bot
Re: [PATCH 2/2] tracing: hist: undo the registration when enabling the trigger fails
Donggeun Yoo
Re: [PATCH 0/2] tracing: hist: two named trigger error paths that free a published trigger
Donggeun Yoo
[PATCH v2] dma-mapping: don't trace the DMA address when the allocation fails
Donggeun Yoo
Re: [PATCH v2] dma-mapping: don't trace the DMA address when the allocation fails
Sean Anderson
Re: [PATCH v2] dma-mapping: don't trace the DMA address when the allocation fails
Marek Szyprowski
[PATCH v1] ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity()
Vincent Donnefort
Re: [PATCH v1] ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity()
sashiko-bot
Re: [PATCH v1] ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity()
Vincent Donnefort
Re: [PATCH v1] ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity()
Google
Re: [PATCH v1] ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity()
Vincent Donnefort
[PATCH] tracing: hist: set the trace clock before registering the trigger
Donggeun Yoo
Re: [PATCH] tracing: hist: set the trace clock before registering the trigger
sashiko-bot
Re: [PATCH] tracing: hist: set the trace clock before registering the trigger
Donggeun Yoo
[BUG?] tracing: unexpected behavior trying to keep IRQ code away from traces
Lahoz Fernando
Re: [BUG?] tracing: unexpected behavior trying to keep IRQ code away from traces
Steven Rostedt
[PATCH v2 0/8] sched: introduce for_each_process_rculock and for_each_thread_rculock
Ye Liu
[PATCH v2 1/8] sched: introduce for_each_process_rculock and for_each_thread_rculock
Ye Liu
Re: [PATCH v2 1/8] sched: introduce for_each_process_rculock and for_each_thread_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 1/8] sched: introduce for_each_process_rculock and for_each_thread_rculock
Oleg Nesterov
Re: [PATCH v2 1/8] sched: introduce for_each_process_rculock and for_each_thread_rculock
Gregory Price
Re: [PATCH v2 1/8] sched: introduce for_each_process_rculock and for_each_thread_rculock
SJ Park
[PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Ye Liu
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
sashiko-bot
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Gregory Price
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Oleg Nesterov
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Gregory Price
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Oleg Nesterov
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Gregory Price
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Oleg Nesterov
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
K Prateek Nayak
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Oleg Nesterov
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Gregory Price
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Peter Zijlstra
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
SJ Park
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Oleg Nesterov
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Peter Zijlstra
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Steven Rostedt
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Peter Zijlstra
[PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
Ye Liu
Re: [PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
sashiko-bot
Re: [PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
Gregory Price
Re: [PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
SJ Park
[PATCH v2 2/8] mm/oom_kill: convert process/thread iterators to for_each_*_rculock
Ye Liu
Re: [PATCH v2 2/8] mm/oom_kill: convert process/thread iterators to for_each_*_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 2/8] mm/oom_kill: convert process/thread iterators to for_each_*_rculock
Gregory Price
[PATCH v2 4/8] mm/memory-failure: convert process iterator to for_each_process_rculock
Ye Liu
Re: [PATCH v2 4/8] mm/memory-failure: convert process iterator to for_each_process_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 4/8] mm/memory-failure: convert process iterator to for_each_process_rculock
Gregory Price
Re: [PATCH v2 4/8] mm/memory-failure: convert process iterator to for_each_process_rculock
SJ Park
[PATCH v2 8/8] security/landlock: convert thread iterator to for_each_thread_rculock
Ye Liu
Re: [PATCH v2 8/8] security/landlock: convert thread iterator to for_each_thread_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 8/8] security/landlock: convert thread iterator to for_each_thread_rculock
Gregory Price
Re: [PATCH v2 8/8] security/landlock: convert thread iterator to for_each_thread_rculock
SJ Park
[PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock
Ye Liu
Re: [PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock
Gregory Price
Re: [PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock
SJ Park
Re: [PATCH v2 0/8] sched: introduce for_each_process_rculock and for_each_thread_rculock
Lorenzo Stoakes (ARM)
[PATCH v2 3/8] mm/ksm: convert process iterator to for_each_process_rculock
Ye Liu
Re: [PATCH v2 3/8] mm/ksm: convert process iterator to for_each_process_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 3/8] mm/ksm: convert process iterator to for_each_process_rculock
Gregory Price
Re: [PATCH v2 3/8] mm/ksm: convert process iterator to for_each_process_rculock
David Hildenbrand (Arm)
[PATCH 08/14] tracing: fix typo "preceeded" in comment
Hemanth Selam
[PATCH] tracing: fix typo "availabe" in comment
Hemanth Selam
[PATCH] tracing: hist: keep the entry count when the stats allocation fails
Donggeun Yoo
Re: [PATCH] tracing: hist: keep the entry count when the stats allocation fails
Google
Re: [PATCH] tracing: hist: keep the entry count when the stats allocation fails
Steven Rostedt
[PATCH] tracing: hist: let values keep the percent and graph modifiers
Donggeun Yoo
Re: [PATCH] tracing: hist: let values keep the percent and graph modifiers
sashiko-bot
Re: [PATCH] tracing: hist: let values keep the percent and graph modifiers
Donggeun Yoo
[PATCH RFC 0/2] mm/mglru: add tracepoints for aging and isolation
Ridong Chen
[PATCH RFC 2/2] mm/mglru: add tracepoint for inc_max_seq
Ridong Chen
Re: [PATCH RFC 2/2] mm/mglru: add tracepoint for inc_max_seq
Barry Song
Re: [PATCH RFC 2/2] mm/mglru: add tracepoint for inc_max_seq
Ridong Chen
[PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
Ridong Chen
Re: [PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
Barry Song
Re: [PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
Ridong Chen
Re: [PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
Barry Song
Re: [PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
Ridong Chen
Re: [PATCH RFC 0/2] mm/mglru: add tracepoints for aging and isolation
Ridong Chen
[PATCH] tracing: hist: free the field rejected for a bad modifier
Donggeun Yoo
Re: [PATCH] tracing: hist: free the field rejected for a bad modifier
sashiko-bot
Re: [PATCH] tracing: hist: free the field rejected for a bad modifier
Donggeun Yoo
[PATCH v15 00/12] tracing: wprobe: x86: Add wprobe for watchpoint
Masami Hiramatsu (Google)
[PATCH v15 03/12] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
Masami Hiramatsu (Google)
Re: [PATCH v15 03/12] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
sashiko-bot
Re: [PATCH v15 03/12] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
Google
[PATCH v15 01/12] x86/mce: Fix hardware debug register corruption on task migration
Masami Hiramatsu (Google)
Re: [PATCH v15 01/12] x86/mce: Fix hardware debug register corruption on task migration
sashiko-bot
[PATCH v15 05/12] tracing/wprobe: Add wprobe (watchpoint probe) trace event support
Masami Hiramatsu (Google)
Re: [PATCH v15 05/12] tracing/wprobe: Add wprobe (watchpoint probe) trace event support
sashiko-bot
Re: [PATCH v15 05/12] tracing/wprobe: Add wprobe (watchpoint probe) trace event support
Google
[PATCH v15 02/12] x86/hw_breakpoints: Make DR7 updates NMI safe
Masami Hiramatsu (Google)
Re: [PATCH v15 02/12] x86/hw_breakpoints: Make DR7 updates NMI safe
sashiko-bot
Re: [PATCH v15 02/12] x86/hw_breakpoints: Make DR7 updates NMI safe
Google
Re: [PATCH v15 02/12] x86/hw_breakpoints: Make DR7 updates NMI safe
Google
[PATCH v15 06/12] x86: hw_breakpoint: Add a kconfig to clarify when a breakpoint fires
Masami Hiramatsu (Google)
Re: [PATCH v15 06/12] x86: hw_breakpoint: Add a kconfig to clarify when a breakpoint fires
sashiko-bot
[PATCH v15 04/12] HWBP: Add modify_local_hw_breakpoint_addr() API
Masami Hiramatsu (Google)
Re: [PATCH v15 04/12] HWBP: Add modify_local_hw_breakpoint_addr() API
sashiko-bot
[PATCH v15 08/12] selftests: tracing: Add syntax testcase for wprobe
Masami Hiramatsu (Google)
Re: [PATCH v15 08/12] selftests: tracing: Add syntax testcase for wprobe
sashiko-bot
[PATCH v15 07/12] selftests: tracing: Add a basic testcase for wprobe
Masami Hiramatsu (Google)
Re: [PATCH v15 07/12] selftests: tracing: Add a basic testcase for wprobe
sashiko-bot
[PATCH v15 12/12] tracing/wprobe: Support BTF struct offset resolution in set_wprobe trigger
Masami Hiramatsu (Google)
Re: [PATCH v15 12/12] tracing/wprobe: Support BTF struct offset resolution in set_wprobe trigger
sashiko-bot
[PATCH v15 09/12] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
Masami Hiramatsu (Google)
Re: [PATCH v15 09/12] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
sashiko-bot
Re: [PATCH v15 09/12] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
Google
[PATCH v15 10/12] selftests: tracing: Add wprobe trigger testcase
Masami Hiramatsu (Google)
Re: [PATCH v15 10/12] selftests: tracing: Add wprobe trigger testcase
sashiko-bot
[PATCH v15 11/12] tracing/wprobe: Support BTF typecast in fetchargs
Masami Hiramatsu (Google)
Re: [PATCH v15 11/12] tracing/wprobe: Support BTF typecast in fetchargs
sashiko-bot
Re: [PATCH v15 00/12] tracing: wprobe: x86: Add wprobe for watchpoint
Jinchao Wang
Re: [PATCH v15 00/12] tracing: wprobe: x86: Add wprobe for watchpoint
Google
Re: [PATCH v15 00/12] tracing: wprobe: x86: Add wprobe for watchpoint
Jinchao Wang
[syzbot] [trace?] WARNING in ring_buffer_map_get_reader (3)
syzbot
Re: [syzbot] [trace?] WARNING in ring_buffer_map_get_reader (3)
syzbot
[PATCH v5 0/5] rv/reactors: fix lockdep warning and add tests
wen . yang
[PATCH v5 1/5] rv/reactors: use LD_WAIT_SPIN as the reactor lockdep wait type
wen . yang
Re: [PATCH v5 1/5] rv/reactors: use LD_WAIT_SPIN as the reactor lockdep wait type
sashiko-bot
[PATCH v5 2/5] rv/reactors: propagate rv_register_reactor() error from reactor init
wen . yang
[PATCH v5 3/5] rv/reactors: export rv_register_reactor() and rv_unregister_reactor()
wen . yang
Re: [PATCH v5 3/5] rv/reactors: export rv_register_reactor() and rv_unregister_reactor()
Gabriele Monaco
Re: [PATCH v5 3/5] rv/reactors: export rv_register_reactor() and rv_unregister_reactor()
Wen Yang
Re: [PATCH v5 3/5] rv/reactors: export rv_register_reactor() and rv_unregister_reactor()
Gabriele Monaco
[PATCH v5 4/5] rv/reactors: add KUnit tests for reactor registration and dispatch
wen . yang
Earlier messages
Later messages