As a result of the recent refactoring of PMC logic out of the phc2sys
program, the pmc_common module has collected two interfaces, one of
which layers on top of the other.  This series names the upper layer
"PMC agent" and places it into its own module.

- Patch #1 moves the existing code without changing it.
- Patch #2 renames the main data structure to something descriptive.
- Patch #3 reworks the code to implement proper data hiding.
- Patches 4 and 5 move helper functions around.

Part II of this series will complete the renaming of the methods of
the PMC agent's public interface.


Richard Cochran (5):
  Introduce the PMC agent module.
  pmc_agent: Rename pmc_node to something more descriptive.
  pmc_agent: Hide the implementation.
  Find a better home for the management TLV ID helper function.
  Find a better home for the management TLV data helper function.

 makefile     |   6 +-
 msg.h        |  24 ++++
 phc2sys.c    |  81 ++++++-----
 pmc_agent.c  | 389 +++++++++++++++++++++++++++++++++++++++++++++++++++
 pmc_agent.h  |  88 ++++++++++++
 pmc_common.c | 338 --------------------------------------------
 pmc_common.h |  34 -----
 7 files changed, 548 insertions(+), 412 deletions(-)
 create mode 100644 pmc_agent.c
 create mode 100644 pmc_agent.h

-- 
2.20.1



_______________________________________________
Linuxptp-devel mailing list
Linuxptp-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/linuxptp-devel

Reply via email to