The main focus of this submission is adding support for testing ADJ_OFFSET with
phc_ctl and querying the maximum supported ADJ_OFFSET adjustment that a device
is capable of. Some other minor cleanups are also included in the submission.

The patch that introduces support for querying the maximum offset supported by
ADJ_OFFSET depends on a kernel patch series (linked below) that is targeted for
kernel 6.5. Previously, sent this series out as an RFC to inquire feedback early
on. Have incorporated that feedback into this submission.

Changes:

  patch 1:
    v2->v3:
      - Eliminate unnecessary tmo variable due to refactor in tc.c.
  patch 5:
    v1->v2:
      - Accounted for conditional formatting changes suggested by Erez.
      - Added pre-emptive return on error since clockadj_step prints an error
        message as suggested by Erez.

Link: https://sourceforge.net/p/linuxptp/mailman/message/38267194/
Link: https://sourceforge.net/p/linuxptp/mailman/message/37871081/
Link: https://sourceforge.net/p/linuxptp/mailman/message/37860292/
Link: https://sourceforge.net/p/linuxptp/mailman/message/37854603/
Link: 
https://lore.kernel.org/netdev/20230612211500.309075-1-rrameshb...@nvidia.com/

Rahul Rameshbabu (5):
  Rename NSEC2SEC as NSEC_PER_SEC and refactor to util.h
  phc_ctl: Add phase command to support ADJ_OFFSET
  phc_ctl: Add maximum offset capability
  phc_ctl: Use pr_notice instead of pr_err for displaying adjusted
    frequency
  phc_ctl: Handle errors returned by various clockadj helpers

 missing.h      |  9 +++---
 phc_ctl.8      |  4 +++
 phc_ctl.c      | 79 ++++++++++++++++++++++++++++++++++++++------------
 port.c         | 14 ++++-----
 port_private.h |  3 +-
 servo.c        |  3 +-
 tc.c           |  9 +++---
 util.h         |  2 ++
 8 files changed, 85 insertions(+), 38 deletions(-)

-- 
2.40.1



_______________________________________________
Linuxptp-devel mailing list
Linuxptp-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/linuxptp-devel

Reply via email to