xiaobai added a comment. xiaobai added inline comments.
================ Comment at: cmake/modules/AddLLDB.cmake:102-104 if(LLDB_BUILD_FRAMEWORK) if(ARG_INCLUDE_IN_FRAMEWORK) + add_dependencies(lldb-framework ${name}) ---------------- labath wrote: > If you reorder this slightly, then you should be able to get rid of the extra > dependency code in main CMakeLists.txt. > Something like this: > ``` > if (ARG_INCLUDE_IN_FRAMEWORK) > add_dependencies(lldb-suite ${name}) > if (LLDB_BUILD_FRAMEWORK) > ... > ``` > > (of course, then the INCLUDE_IN_FRAMEWORK arg will become misnamed, but that > can be solved by renaming it to INCLUDE_IN_SUITE) This is a pretty good idea imo. I think it'll make the dependency tracking much easier. The lldb-framework target then becomes a small target. https://reviews.llvm.org/D48060 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits