The lib suffix "linux" (libodp-linux, libodphelper-linux) is harcoded pretty 
much everywhere in the build system.
The goal of this series is to allow each platform to define its library suffix 
so they don't have to touch the generic files but simply the platform specific 
files.

v2:
- Moved to master (instead of monarch_lts)
- rename ODP_LIB_NAME to ODP_LIB_FLAVOR
- Supports empty ODP_LIB_FLAVOR (libs will be libodp.a libodphelper.a
- Fix mising replace (helpers, linux-generic specific tests)


Nicolas Morey-Chaisemartin (6):
  m4: add platform configurable library suffixes
  platform: move pkgconfig include to linux-generic
  test: use ODP_LIB_FLAVOR to generate libodp name
  helper: use ODP_LIB_FLAVOR to generate libodp name
  example: use ODP_LIB_FLAVOR to generate libodp name
  platform: use ODP_LIB_FLAVOR to generate libodp name

 configure.ac                                 | 3 +--
 example/Makefile.inc                         | 2 +-
 helper/Makefile.am                           | 6 +++---
 helper/test/Makefile.am                      | 6 +++---
 platform/Makefile.inc                        | 6 +++---
 platform/linux-generic/Makefile.am           | 4 ++--
 platform/linux-generic/m4/configure.m4       | 6 +++++-
 test/Makefile.inc                            | 2 +-
 test/common_plat/validation/api/Makefile.inc | 2 +-
 test/linux-generic/Makefile.inc              | 2 +-
 10 files changed, 21 insertions(+), 18 deletions(-)

Reply via email to