On Tue, 17 Apr 2001, dcross - David Cross wrote:

> Sorry to drag the list off-topic, but I've a Perl question!
> I'm having trouble building HTML::Parser on an AIX box. It's the first time
> I've tried to build and install an XS module, so it's quite possible that
> it's a wider issue.
> The 'make' seems to go ok, but when I run 'make test' I get the same error
> for each test file:
> t/unbroken-text.....Can't load 'blib/arch/auto/HTML/Parser/Parser.so' for
> module HTML::Parser: dlopen: blib/arch/auto/HTML/Parser/Parser.so: A file or
> directory in the path name does not exist. at
> /usr/local/lib/perl5/5.00502/aix/DynaLoader.pm line 168.
>  at t/unbroken-text.t line 2
> BEGIN failed--compilation aborted at t/unbroken-text.t line 2.
> dubious
>         Test returned status 2 (wstat 512, 0x200)
> Running ls -l blib/arch/auto/HTML/Parser/Parser.so shows that the file
> exists and is readable.
> The build process seems to be using IBM's own C compiler rather than gcc.
> Does anyone have any clues about this?

Is AIX one of those OS that requires you to set LD_LIBRARY_PATH or some
equivalent to load a shared library - although this shouldnt be the case
for the binary part of a module because dynaloader searches in a bunch of
places relative to @INC ...

Is it some other .so file that Parser.so uses ? What does ldd tell you ?


Reply via email to