Here is my problem, and any and all help is appreciated.

I am trying to use a thesis class from latex in lyx.  I have read the
customization file and also many of the emails to this archive and I must
admit I am still stumped.
What is happening: I can get the lyx document menu to show my class
(ucdthesis), but it tells me 
        "unable to use document class.  Reverting to original class"
What I have Done: I created a ucdthesis.layout file in ~/.lyx/layouts
which is as follows

#% our love is a many splendored thing or something
#   \DeclareLaTeXClass[ucdthesis]{ucdthesis} 

>>> then because I read it on one of these posts, i ran texhash (which
apparently is just a pointer to mktexlsr).  I have stored in many
directories my file ucdthesis.cls.  I have stored it in
~/.lyx/tex,~/.lyx/layouts,~texmf, and /usr/share/texmf/tex/latex/misc.
If it is supposed to transfrom the ucdthesis.cls file into something, i
have not seen it.  Oh, and of course I ran reconfigure in lyx and
restarted it.  I am a broken man and in need of help, what have I
missed(not knowing a bit of latex)?

Did I:
1)not put the .cls file in the correct place?
2)incorrectly ran mktexlsr?
3)have a foul .cls file?
4)have trouble reading documention or more likely,
5)anger the gods

        -Efram Burlingame

ps. I like lyx and the people in my lab are becoming excited about its
power.  If you can help me surmount this problem you will have gained at
least 10 people more to the cause.  viva lyx!

Reply via email to