Am 26.08.2017 um 12:20 schrieb Kornel Benko:
Am Samstag, 26. August 2017 um 10:31:49, schrieb Wolfgang Engelmann 
<engelm...@uni-tuebingen.de>
What worked for me: I started |tlmgr| in gui mode with

|sudo env PATH="$PATH" tlmgr --gui |
That's the way it should work, if you install as root.

and then in the third menu chose the last item but one (in my German
menu, that is menu "Aktionen" (actions?) and item "Verwaltung der
symbolischen Links" (administration of symbolic links?). In the
ensuing dialogue window I clicked the button "Symbolische Links
erneuern" (renew symbolic links?). Now

|sudo tlmgr --OPTIONS |

works without problems. I'm sure there's also a command line way of
doing this

-----------------------

and another note:

You really don't have to add the directory of |tlmgr| to the path. A
simple quick solution is using |which|, e.g.:

|sudo $(which tlmgr) update --list -------------------- |
It should be like the previous, you have to set PATH
        # sudo env PATH="$PATH" tlmgr update --list

Both proposals are not working for me. In the first proposal the actions
menu is grayed out, in the second: update command not found
Wolfgang
What I would suggest (if you are user engelmann) is:
        # cd /usr/local/texlive
        # sudo chown -R engelmann.engelmann .
But that is dangerous, if you are not alone on your system. It is up to you to 
decide.
If you do this, then from now on you should not use 'sudo' anymore in 
connection with texlive.

        Kornel
Thanks again, Kornel,
I used your chown suggestion and it worked (by the way, why is engelmann.engelmann used?). After reconfigure I can now work with lyx again. That's good.
Wolfgang

Reply via email to