Hello,

I'm tried this on my Mac, too.
I downloaded the german aspell dictionary, unzipped it, and put in into the 
cocoAspell-Folder, changed the path in Lyx etc.
A first test ended up in the same error you reported.

Then I looked into the dictionary folder and saw that there is no de-common-rws 
file.

Then I realized what the problem is:
I didn't compile the aspell dictionary! (the README-file tells me I have to do 
this ;-))
CocoAspell does this automatically if you open its preference pane 
(Systemeinstellungen): If there's a new dict in the path, compiling starts.
After compiling be sure that you have checked at least "German" in the 
CocoAspell preference pane.

So maybe you have forgotten this compilation step, too?

Kind regards,
Johannes


After this spellchecking in German works for me.

Am 16.07.2010 um 01:06 schrieb iustifico:

> Does someone know, how to fix this error?
> 
> Kind regards,
> iustifico
> 
> Am 12.07.2010 um 22:48 schrieb iustifico:
> 
>> Am 12.07.2010 um 20:16 schrieb BH:
>>> 
>>> Did you try reconfiguring LyX? (LyX > Reconfigure, then restarting LyX)
>> 
>> Yes. I got the English dictionary to run. I figured out, that the cursor 
>> must be in the beginning of the file, so that the spellchecker can find 
>> errors. If you are at the end of the file with the cursor, it doesn't find 
>> anything.
>> 
>> Now I am trying to get the german dictionary to run. I downloaded the file
>> 
>> aspell6-de-20030222-1.tar.bz2
>> 
>> from the cocoAspell-ftp-server and after expanding it i put it in
>> 
>> /Library/Application Support/cocoAspell/
>> 
>> Then I changed the entry in "alternative language" under preferences -> 
>> languages -> spellchecking to
>> 
>> /Library/Application Support/cocoAspell/aspell6-de-20030222-1/deutsch.alias
>> 
>> Now it looks like this.
>> <Bildschirmfoto 2010-07-12 um 20.47.48.png>
>> 
>> I changed this one too:
>> <Bildschirmfoto 2010-07-12 um 20.48.33.png>
>> 
>> But I get this error:
>> <Bildschirmfoto 2010-07-12 um 22.46.58.png>
>> Kind regards,
>> iustifico
> 

Reply via email to