On 13/05/2014 7:46 a.m., Georg Baum wrote:
aparsloe wrote:

On 11/05/2014 8:31 a.m., didiergab...@free.fr wrote:

I have problem wth lyx2.1 (on windows 7 64bits)... I often copy images
from adobe reader with the embedded tool and paste directly on lyx
(ctrl+V)... I have a error message "Can not open Metafle to EPS converter
printer" (without "i" on "Metafle" :o)

When I try the conversion directly from Lyx2.1 dir\bin\metafile2eps.exe
the same error occur... Any idea ?
Is the virtual printer installed which is used by metafile2eps.exe? Maybe
something wnet wrong during installation.

I've also got LyX2.1 on  64 bit Windows 7, and Adobe Reader X, and the
copy and paste works without problems, so this looks like a problem at
your end rather than with LyX.
Also for copying vector images? metafile2eps.exe is not used for bitmap
images or text. You can easily see whether a vector imagtes was copied by
looking at the type of the copied image: If it is eps, the original image
was in vector format, and metafile2eps.exe worked.

I was hasty in my response. In Adobe Reader X, under the Edit menu, there's the option Take a Snapshot. I assume this is the "embedded tool" referred to. When I copy a figure from the pdf and then go to paste it into LyX I get asked first to save the file, always as an .emf file although that can be changed to .png if I wish. The first one I paste into LyX reproduces the copied figure. Copying and pasting other figures (after saving in .emf format) generally insert into LyX figures that are about 25 times too big. I have to scale to about 4% for the Adobe --> LyX --> Adobe round trip to reproduce a figure about the size of the original. But this doesn't happen always and seems to depend on whether I've saved a file at some point as .png (which seems to paste at the right size). So, it works for a one-off, but clearly not flawlessly for a number of copy-pastes.


Reply via email to