Sorry if this has been discussed before. I searched and didn't see
usable results.

I'm new to Perl and newer to Perl on Mac, but I thought I understood
CPAN and use. I installed Mac::Growl using CPAN from the command line.
I'm using the Perl distro included with Leopard. My program contains
the following lines:

use Mac::Growl ':all';
BEGIN { $Mac::Growl::base = 'Mac::Applescript' }

(I've tried it with the lines reversed with the same results. Just
reaching with no clue.)

I get this error when I run it:

Can't locate Mac/ in @INC (@INC contains: /System/Library/Perl/
5.8.8/darwin-thread-multi-2level /System/Library/Perl/5.8.8 /Library/
Perl/5.8.8/darwin-thread-multi-2level /Library/Perl/5.8.8 /Library/
Perl /Network/Library/Perl/5.8.8/darwin-thread-multi-2level /Network/
Library/Perl/5.8.8 /Network/Library/Perl /System/Library/Perl/Extras/
5.8.8/darwin-thread-multi-2level /System/Library/Perl/Extras/5.8.8 /
Library/Perl/5.8.6 /Library/Perl/5.8.1/darwin-thread-multi-2level /
Library/Perl/5.8.1 .) at ../bin/ line 5.
BEGIN failed--compilation aborted at ../bin/ line 5.

CPAN seems to be writing files to /var/root/perl/lib/perl5/Extras/
5.8.8/, but there isn't anything in /var/root/. I've searched for it
with find and mdfind. I can't find where modules are being installed
and neither can Perl. How can I get CPAN to install to somewhere in

Reply via email to