On Apr 12, 2008, at 4:57 AM, Rainer Müller wrote:
Rainer Müller wrote:[EMAIL PROTECTED] wrote:I'm not quite happy with the name --recursive, because it does not imply in which direction we recurse. I would rather propose something like --with-dependents or --follow-dependents. Although this is longer, but much more clear. We were also talking about 'recursive dependencies' before, especially for 'port deps'. But in that case it was meant following dependencies, not dependents. So --recursive might really lead to confusion here. In order to provide a consistent interface, we should define two options for this. One for following dependencies and one for following dependents. (And even one for doing both?) Currently, we also have the global -R und -n flags which are only used by upgrade and -u which is used by uninstall and upgrade. In my opinion these should not be global because they are only used by one or two targets. Therefore these should use the same naming convention.Revision34977 <http://trac.macosforge.org/projects/macports/changeset/34977 >Author [EMAIL PROTECTED] Date 2008-03-13 07:13:51 -0700 (Thu, 13 Mar 2008)Log MessageAdd new --recursive option to port uninstall to uninstall dependents (#14637)Could we please find a better solution here before we branch off another release? Any reply appreciated.
I can see a use for both directions, so I guess having options for both directions would be nice. But also a name like "follow- dependents" or "also-dependents" would be clearer.
-Bill
smime.p7s
Description: S/MIME cryptographic signature
_______________________________________________ macports-dev mailing list [email protected] http://lists.macosforge.org/mailman/listinfo/macports-dev
