Pat, look here for instructions on how to install qt4 on systems upgraded with 
LibCxxOnOlderSystems.

<https://trac.macports.org/ticket/51844>

There is a patch there I submitted about a month ago, and your issue is likely 
the same kind of issue I had, given similar systems.


It is labelled as being a patch to port qt4-mac, so you know you can search for 
issues and patches against specific ports in the tracker:

<https://trac.macports.org/wiki/Tickets> 

and put qt4-mac into the search box, and you'll see what issues and fixes have 
been found -- will save you some time.



It doesn't look like there is much enthusiasm for applying the patch I made to 
the actual portfile, though, so you might need to do that yourself if you want 
it to work.

It does ultimately work, though:

$ port -v installed qt4*
The following ports are currently installed:
  qt4-mac @4.8.7_4 (active) platform='darwin 10' archs='x86_64'
  qt4-mac-sqlite3-plugin @4.8.7_1 (active) platform='darwin 10' archs='x86_64'



Best,

Ken


On 2016-09-16, at 4:08 PM, [ftp83plus] wrote:

> Hello all, 
> 
> I want to install cutecom on Mac OS X 10.6.
> 
> As a dependency, qt4 needs to be installed as well, but fails:
> http://pastebin.com/YMLLEvZ1 (cut because exceeded 512kb)
> 
> Why?
> Pat
> _______________________________________________
> macports-users mailing list
> macports-users@lists.macosforge.org
> https://lists.macosforge.org/mailman/listinfo/macports-users

_______________________________________________
macports-users mailing list
macports-users@lists.macosforge.org
https://lists.macosforge.org/mailman/listinfo/macports-users

Reply via email to