> On Apr 7, 2018, at 11:58 AM, Adam Dershowitz <de...@alum.mit.edu> wrote:
> 
> Did you mistype the echo command? 
> The rsync says build DOT openmodelica.org <http://openmodelica.org/>
> while the error shows
> build HYPHEN openmodelca.org <http://openmodelca.org/>
> 
> --Adam
> 
> 
> 
>> On Apr 7, 2018, at 2:56 PM, Ken Cunningham <ken.cunningham.web...@gmail.com 
>> <mailto:ken.cunningham.web...@gmail.com>> wrote:
>> 
>> 
>> 
>>> On Apr 7, 2018, at 11:51 AM, Ryan Schmidt <ryandes...@macports.org 
>>> <mailto:ryandes...@macports.org>> wrote:
>>> 
>>> 
>>> On Apr 7, 2018, at 13:50, Murray Eisenberg wrote:
>>> 
>>>> What’s happening now is befuddling to me. Doing the step 
>>>> 
>>>>   echo rsync://build.openmodelica.org/macports/ 
>>>> <rsync://build.openmodelica.org/macports/> >> 
>>>> /opt/local/etc/macports/sources.conf
>>>> 
>>>> as root (sudo su - ) seems to have worked, as 
>>>> /opt/local/etc/macports/sources.conf now ends with:
>>>> 
>>>>   rsync://rsync.macports.org/release/tarballs/ports.tar 
>>>> <rsync://rsync.macports.org/release/tarballs/ports.tar> [default]
>>>>   rsync://build-openmodelica.org/macports/ 
>>>> <rsync://build-openmodelica.org/macports/>
>>>> 
>>>> However, continuing as root, doing the step  
>>>> 
>>>>    port selfupdate
>>>> 
>>>> gives:
>>>> 
>>>>    Error: Synchronization of the local ports tree failed doing rsync
>>> 
>>> Use the -v flag to get more information about why it failed:
>>> 
>>> sudo port -v selfupdate
>>> 
>> 
>> 
>> looks like the domain name doesn’t exist.
>> 
>> Command failed: /usr/bin/rsync -rtzvl --delete-after  
>> '--exclude=/PortIndex*' rsync://build-openmodelica.org/macports/ 
>> <rsync://build-openmodelica.org/macports/> 
>> /opt/local/var/macports/sources/build-openmodelica.org/macports 
>> <http://build-openmodelica.org/macports>
>> Exit code: 10
>> Error: Synchronization of the local ports tree failed doing rsync
>> port sync failed: Synchronization of 1 source failed
>> 
>> Kens-MacBook-Pro:~$ nslookup build-openmodelica.org 
>> <http://build-openmodelica.org/>
>> 
>> ** server can't find build-openmodelica.org 
>> <http://build-openmodelica.org/>: NXDOMAIN
>> 
>> 
> 


and sure enough, using the proper name

build.openmodelica.org <http://build.openmodelica.org/>

works just fine.

Another crisis averted.

K

Reply via email to