After uninstalling the +atlas variant of octave and its direct or indirect deps 
or dependent’s sundials, SuiteSparse. qrupdate, and arpack, I began 
reinstalling with the +accelerate variant.

I used (with sudo):

  port install octave 
+app+accelerate+docs+fltk+gfortran+graphicsmagick+qt5+sound 

but when the octave installation was running it tried to install qrupdate and 
hit error:

  Error: Failed to fetch qrupdate: must set at least one Fortran variant (e.g. 
+gfortran, +gccX, +g95)

So I quit that, cleaned everything, and directly tried...

  port install qrupdate +accelerate +gfortran

… and got same error message that I must set a Fortran variant.

Now I’m puzzled: the qrupdate port says +gfortran is such a variant, then fails 
to accept it.  And in fact:

port info qrupdate
qrupdate @1.1.2_5 (math)
Variants:             [+]accelerate, atlas, g95, gcc44, gcc45, gcc46, gcc47,
                      gcc48, gcc49, gcc5, gcc6, [+]gcc7, openblas, universal

(I see what Ken Cunningham said in separate message about blowing up MacPorts 
and starting over, but I have quite a number of config files, e.g., for apache, 
mysql, php, phpmyadmin, that I’d hate to set up again; that could take days. 
Unless I misunderstand what Ken said.)

> On 16 Apr2018, at 3:55 PM, Adam Dershowitz <de...@alum.mit.edu> wrote:
> 
> As an datapoint, but not completely answering your question.  I have the 
> following installed and all working:
> 
> sundials @3.1.0_1+accelerate+fortran_klu+gfortran+mpich (active)
> octave @4.2.2_1+accelerate+app+docs+fltk+gfortran+graphicsmagick+qt4+sound 
> (active)
> SuiteSparse @4.2.1_4+accelerate (active)
> openmodelica-devel 
> @1.13.0~dev-882-g45503fc_0+gfortran5+omnotebook+qt+sundials (active)
> 
> 
> I don’t recall the installation order, or if any of those are not the default 
> variant.  
> 
> --Adam
> 
> 
> 
>> On Apr 16, 2018, at 3:39 PM, Murray Eisenberg <murrayeisenb...@gmail.com 
>> <mailto:murrayeisenb...@gmail.com>> wrote:
>> 
>> From a post on the OpenModelica forum, I learned that the trouble was that I 
>> did not have the lapack port installed, and so the openmodelica-devel 
>> configure was attempting to use libatlas from atlas instead.
>> 
>> Subsequently, after cleaning everything, I did install lapack 
>> @3.8.0_0+gfortran. However, the configure still fails. Undoubtedly this is 
>> due to the fact that the following both involve atlas:
>> 
>>    octave @4.2.2_1+app+atlas+docs+fltk+gfortran+graphicsmagick+qt5+sound 
>>    SuiteSparse @4.2.1_4+atlas  [NB: octave depends on SuiteSparse]
>> 
>> I wonder if the following ploy might work (this is the MacPorts part of the 
>> question):
>> 
>>    (1) uninstalling the +atlas variants of SuiteSparse and octave;
>> 
>>    (2) install openmodelica-devel (assuming that the presence of atlas and 
>> libatlas was the sole issue); then finally
>> 
>>    (3) reinstalling the +atlas variants of octave and SuiteSparse.
>> 
>> Note that openmodelica _seems_ to use SuiteSparse as well as lapack. And 
>> sundials has a library dependency on SuiteSparse.
>> 
>> Further information:
>> 
>> [me:~]$ sp dependent atlas
>> SuiteSparse depends on atlas
>> arpack depends on atlas
>> octave depends on atlas
>> qrupdate depends on atlas
>> 
>> [me:~]$ sp deps octave
>> Full Name: octave 
>> @4.2.2_1+accelerate+app+docs+fltk+gfortran+graphicsmagick+qt5+sound
>> Build Dependencies:   gawk, icoutils, librsvg, grep, findutils, gsed, flex, 
>> bison, gperf, perl5, pkgconfig, gcc7, pkgconfig, librsvg, texinfo, 
>> texlive-basic, texlive-latex, texlive-fonts-recommended
>> Library Dependencies: python27, ghostscript, gnuplot, less, ncurses, 
>> readline, pcre, SuiteSparse, qhull, zlib, hdf5, fftw-3, fftw-3-single, glpk, 
>> curl, qrupdate, arpack, fontconfig, freetype, gl2ps,
>>                      vecLibFort, libgcc, qscintilla-qt5, fltk, libsndfile, 
>> portaudio, GraphicsMagick, qt5-qtbase, qt5-qttools
>> Runtime Dependencies: epstool, ghostscript, fig2dev, pstoedit
>> 
>> [me:~]$ sp deps openmodelica-devel 
>> Full Name: openmodelica-devel 
>> @1.13.0~dev-895-g0365526_0+gfortran5+omnotebook+qt+sundials
>> Build Dependencies:   gtime, gsed, cmake, pkgconfig, autoconf, automake, 
>> libtool
>> Library Dependencies: lp_solve, gettext, omniorb, readline, qjson, libgcc, 
>> gcc5, sundials, qt4-mac, qwt52
>> Runtime Dependencies: omlib-modelica-3.2.1
>> 
>>> On 7 Apr2018, at 4:34 PM, Ken Cunningham <ken.cunningham.web...@gmail.com 
>>> <mailto:ken.cunningham.web...@gmail.com>> wrote:
>>> 
>>> 
>>> 
>>>> On Apr 7, 2018, at 1:13 PM, Murray Eisenberg <murrayeisenb...@gmail.com 
>>>> <mailto:murrayeisenb...@gmail.com>> wrote:
>>> 
>>> With a small change in the openmodelica-devel Portfile that I did prior to 
>>> starting the build (so it would use gcc7 for fortran), all of 
>>> openmodelica-devel built through to completion for me on a current Xcode 
>>> and 10.13 system, using no compiler variants, and only +libraries.
>>> 
>>> set gfortran_versions {4.3 4.4 4.5 4.6 4.7 4.8 4.9 5 6 7}
>>> set default_fortran_variant +gfortran7
>>> 
>>> 
>>> Ken
>> 
>> ---
>> Murray Eisenberg                     murrayeisenb...@gmail.com 
>> <mailto:murrayeisenb...@gmail.com>
>> 503 King Farm Blvd #101      Home (240)-246-7240
>> Rockville, MD 20850-6667     Mobile (413)-427-5334
>> 
>> 
> 

---
Murray Eisenberg                        murrayeisenb...@gmail.com
503 King Farm Blvd #101 Home (240)-246-7240
Rockville, MD 20850-6667        Mobile (413)-427-5334


Reply via email to