> On Apr 7, 2018, at 4:02 PM, Ken Cunningham <ken.cunningham.web...@gmail.com> 
> wrote:
>> On Apr 7, 2018, at 12:54 PM, Murray Eisenberg <murrayeisenb...@gmail.com 
>> <mailto:murrayeisenb...@gmail.com>> wrote:
>> Ouch, yes, my disastrous typo in the repository name, sorry. (The first time 
>> I tried, without using "sudo su -“, I had copied the “echo rsync” command 
>> directly from the https://www.openmodelica.org/download/download-mac 
>> <https://www.openmodelica.org/download/download-mac> instructions. But the 
>> second time, using "sudo su -“ I just typed the command, clearly a mistake. 
>> Now the sync with that repository has completed successfully, I’m watching 
>> the long installation process proceed.
> there may be some hiccups in this software yet to be discovered
> I note it tries to link to both -stdlib=libc++ and -stdlib=libstdc++ on the 
> link line, and that just can’t be good…
> /usr/bin/clang++ -shared 
> -Wl,-rpath,'@loader_path/../lib/x86_64-darwin17.5.0/omc/' -install_name 
> @rpath/libomcruntime.dylib -o libomcruntime.dylib Error_omc.o Print_omc.o 
> ErrorMessage.o systemimplmisc.o System_omc.o Lapack_omc.o Settings_omc.o 
> UnitParserExt_omc.o unitparser.o IOStreamExt_omc.o Socket_omc.o ZeroMQ_omc.o 
> getMemorySize.o is_utf8.o ptolemyio_omc.o SimulationResults_omc.o 
> omc_communication.o omc_communication_impl.o Corba_omc.o -L 
> "/opt/local/var/macports/build/_opt_local_var_macports_sources_build.openmodelica.org_macports_lang_openmodelica-devel/openmodelica-devel/work/openmodelica_1.13.0~dev-866-gb1271a6/build/lib/x86_64-darwin17.5.0/omc/"
>  -lOpenModelicaRuntimeC -L/opt/local/lib -Wl,-headerpad_max_install_names 
> -arch x86_64   -lomcgc -lm -lpthread  -lstdc++ -Wl,-undefined 
> -Wl,dynamic_lookup -llpsolve55 -lcolamd  -lzmq  -pipe -Os -stdlib=libc++ 
> -arch x86_64 -stdlib=libstdc++ -std=c++11
> clang: warning: libstdc++ is deprecated; move to libc++ [-Wdeprecated]
> clang: warning: libstdc++ is deprecated; move to libc++ [-Wdeprecated]
> Using any of the compiler variants provided is probably just wrong — if you 
> want /usr/bin/clang++ don’t use any of the them, it appears. The clang 
> variant gives you macports-clang-3.8.
> Also, installing both gcc5 and gcc7 and libgcc6 and libgcc just seems nutty, 
> so I added gcc6 and gcc7 to the fortran variants — but that has nothing to do 
> with the above.
> There are advantages to having your ports in the main repo, and having all of 
> us look them over.
> Ken

I know that a long time back, the default set of compilers didn’t work with 
OpenModelica, but that for a few years at least, the default set of variants 
has worked fine for building and using it.  Those instructions have probably 
just not been updated in a long time.  

I don’t know about the link issue, but I haven’t yet seen any problem caused by 
it….so far (in years of use)


Reply via email to