On Nov 9, 2019, at 11:04, Werner LEMBERG wrote:

> I've installed perl's `PAR` module, needed for TeXLive's (self-compiled)
> `biber` binary, with
> 
>  sudo cpan-5.26 install PAR
> 
> on my up-to-date Lion box (using MacPorts from git).  However,
> executing `biber --help` fails with
> 
>  Perl lib version (5.26.3) doesn't match executable
>    'perl' version (5.26.1) at
>    /opt/local/lib/perl5/5.26/darwin-thread-multi-2level/Config.pm line 62.
>  Compilation failed in require at /opt/local/lib/perl5/site_perl/5.26/PAR.pm 
> line 7.
> 
> Indeed, port shows
> 
>  port info perl5.26
>  -> perl5.26 @5.26.3_2 (lang)
> 
>  port info perl5
>  -> perl5 @5.26.1 (lang)

The version number of the perl5 port doesn't matter, because the perl5 port 
doesn't install anything other than symlinks to the files installed by another 
port. Which other port depends on which variant of the perl5 port you have 
installed.

If you really want to use perl 5.26, then verify that


port installed perl5


prints


The following ports are currently installed:
  perl5 @5.26.1_0+perl5_26 (active)


and that


which perl


prints


/opt/local/bin/perl


and that


/opt/local/bin/perl -v


prints


This is perl 5, version 26, subversion 3 (v5.26.3) built for 
darwin-thread-multi-2level

Copyright 1987-2018, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl".  If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.


Note that perl5.28 is available and is the default perl in MacPorts at this 
time. perl5.30 is also available in MacPorts but may not quite be ready yet; 
for example, there is no perl5_30 variant of the perl5 port yet.

Reply via email to