On Tue, Sep 22, 2009 at 10:08 AM, Sebastian Kayser <[email protected]> wrote: > I don't quite like the PROTOTYPE_ prefix from a user perspective when it > comes to variable naming (it exposes internal details), but it feels a > bit cleaner to me right now. > > 1) Generic: possible prototype adjustments are not restricted to > USERGROUP related actions. You might only want to set the suid bit for > example.
The values from USERGROUP_* can be passed along (aliases?) for PROTOTYPE_* variables. > 2) Consistent naming: GAR has a suffix way of declaring things right now > (PKGFILES_, CATALOGNAME_, ...), which i think we should be consistent > with when it comes to new features. The reason why I wrote USERGROUP_mytweaks_USER instead of USERGROUP_USER_mytweaks is because the latter suggests that there's "the" user for USERGROUP. Perhaps it's just me. I don't insist, anyway, I just think it's more intuitive, because it follows the logic of getting from the general to the specific: first, I know I'm going to do something with users and groups; second, I know I'm going to have a name for a specific tweak I'm doing; and third, I know what specifics is my tweak going to have. But I don't insist, if others think that suffix is better, I don't have a problem with it. It just has to be well-documented, and GAR stuff usually is well documented. (yey for the GAR Variable Reference page!) Maciej _______________________________________________ maintainers mailing list [email protected] https://lists.opencsw.org/mailman/listinfo/maintainers
