Excerpts from rupert THURNER's message of Sat Apr 09 07:16:27 -0400 2011: Hi Rupert,
> when doing a minor upgrade to mercurial, checkpackage somehow got > the idea mercurial should be named now py_mercurial. was there an > issue filed against py_checkpackage that says it should get > english_implemented like this, or in other english_words, > english_who english_checks py_checkpackage? The CSWpy-somepkg/py_somepkg is the generally agreed upon convention for naming. It lines up with CSWpm-otherpkg/pm_otherpkg, CSWrb18-newgem/rb18_newgem, CSWphp5-module/php5_module, etc. More generally, it lines up with the preference to use hyphen and underscore to separate parts of names -doc/_doc, -dev/_doc, etc. You can easily rename an existing package by doing: PACKAGES += CSWpy-newpkg OBSOLETED_BY_CSWpy-newpkg = CSWpyoldpkg I don't see pymercurial listed on our packages page though, so that's either not an issue for you or there is a missing/messed up database entry. Thanks -Ben -- Ben Walton Systems Programmer - CHASS University of Toronto C:416.407.5610 | W:416.978.4302 _______________________________________________ maintainers mailing list [email protected] https://lists.opencsw.org/mailman/listinfo/maintainers .:: This mailing list's archive is public. ::.
