Have you tried to connect to the sql server outside of mapserver using the same credentials? ie: make sure the the mapserver user is a valid user to do the connection with.

-Steve W

On 10/13/2016 10:18 AM, Vogt, Robert   (RCIS) wrote:
This is the full error...
502 - Web server received an invalid response while acting as a gateway or 
proxy server.
There is a problem with the page you are looking for, and it cannot be 
displayed. When the Web server (while acting as a gateway or proxy) contacted 
the upstream content server, it received an invalid response from the content 
server.

-----Original Message-----
From: mapserver-users [mailto:mapserver-users-boun...@lists.osgeo.org] On 
Behalf Of Vogt, Robert (RCIS)
Sent: Thursday, October 13, 2016 10:12 AM
To: mapserver-users@lists.osgeo.org
Subject: [mapserver-users] MapServer IIS7

Good morning,

I originally set up MapServer with WS4W and Apache server...I now have a 
requirement to put this on the same domain as our application which runs in 
IIS7.

I have created the site and pointed my application at it and the results are 
mixed...

Map files that are pointed at lizardtech for their source are working but map 
files that are pointed at SQL for their source are giving a 502(bad gateway) 
error.

All map files worked when served through Apache, has anyone run into this or 
know what I should look at to fix it?

Your help is greatly appreciated!!

*******************************************
******** Map File ***************************

MAP
  IMAGETYPE      PNG24
  CONFIG "PROJ_LIB" "E:/RCIS/Web/MapServerDlls/projlib"
  SIZE           256 256
  FONTSET "E:/RCIS/Web/MapServerDlls/content/fontset.txt"
  IMAGECOLOR     255 255 255
  TRANSPARENT ON
  PROJECTION
     "init=epsg:4326"
  END
  WEB
  METADATA
    "wms_title" "sections"
        "wms_enable_request"  "*"
        END
  END
        LAYER
                NAME "States"
                TYPE POLYGON
                STATUS ON
                LABELCACHE ON
                PROCESSING 'LABEL_NO_CLIP=1'
                CONNECTIONTYPE PLUGIN
                PLUGIN "msplugin_mssql2008.dll"
                CONNECTION "OurConnectionString"
                DATA "shape(geography),ST_NAME_MC from NATIONALDB.sde.STATES USING 
INDEX STATES_SIDX USING UNIQUE STATES_ID USING SRID=4269"
                LABELITEM    "ST_NAME_MC"
                PROCESSING "CLOSE_CONNECTION=DEFER"
                CLASS
                        STYLE                   
                         OUTLINECOLOR 000 153 000
                         WIDTH 3
                        END
                         LABEL
                                COLOR 000 153 000
                                TYPE TRUETYPE
                                FONT Arial
                                SIZE 12
                                ANTIALIAS FALSE
                                POSITION AUTO
                                PARTIALS FALSE
                                                
                        END
                END             
        PROJECTION
                 "init=epsg:4326"
        END
        END     
END
_______________________________________________
mapserver-users mailing list
mapserver-users@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/mapserver-users
_______________________________________________
mapserver-users mailing list
mapserver-users@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/mapserver-users



---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

_______________________________________________
mapserver-users mailing list
mapserver-users@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/mapserver-users

Reply via email to