http://yum.mariadb.org/10.2/rhel6-x86/rpms/

that shows pretty clear that the "backup" subpackage is in the same folder as the server and other subpackages which is logical because when you build from source it's just a binary falling out of the build process

frankly you are not supposed to install mariadb-backup 10.2.13 when you server and libraries are 10.1.x or even 5.5.x - that's not how things work

Am 14.02.2018 um 12:35 schrieb Reindl Harald:
Am 14.02.2018 um 12:22 schrieb Florent B:
I'm sorry but that's what not I mean.

My message was just a suggestion, to have a "meta-package" for Debian repository, like we have a meta-package "mariadb-server" that points to "mariadb-server-10.2" (for example, if you installed 10.2 repository).

In my deployment script, I just install "mariadb-server", without specifying version. I would like to do the same for "mariadb-backup". For now, I have to specify version of package : mariadb-backup-10.2. It could be nice to have a "mariadb-backup" meta-package to point automatically to the latest version available.

stop talking about metapackages DAMNED!

you mean "mariadb-backup" in it's last recent point-version should be in the 10.2 or 10.1 repository - why don't you say it then?

don't get me wrong but it's hard when people fail to say what they mean and every response is a new riddle

On 14/02/2018 12:08, Vladislav Vaintroub wrote:

The latest backup will not work with your 10.1 server. Mariabackup version should match server version that you have on the same box.

mariabackup from 10.1 appears to work with 5.5 and 10.0, but this is merely by luck and by accident.

*From: *Florent B <mailto:flor...@coppint.com>
*Sent: *Wednesday, February 14, 2018 11:58 AM
*To: *maria-discuss@lists.launchpad.net <mailto:maria-discuss@lists.launchpad.net>
*Subject: *Re: [Maria-discuss] mariadb-backup meta deb package

On 14/02/2018 11:16, Reindl Harald wrote:

> Am 14.02.2018 um 10:51 schrieb Florent B:

>> Wouldn't be nice to have a metapackage mariadb-backup in Debian

>> repository, that depends on the current best version

>> (mariadb-backup-10.2, etc..) ?

>> Like "mariadb-server" package in fact

> you missed to describe the problem you want to solve by step in with a

> solution which is always the wrong start because in case you didn't

> understand the real problem any solution is wrong

I just want to install the latest mariadb-backup package, without

checking version by myself (10.1, 10.2...).

Exactly the same as the "mariadb-server" metapackage for Debian, which

points to latest version possible.

_______________________________________________
Mailing list: https://launchpad.net/~maria-discuss
Post to     : maria-discuss@lists.launchpad.net
Unsubscribe : https://launchpad.net/~maria-discuss
More help   : https://help.launchpad.net/ListHelp

Reply via email to