I am not sure this is a good idea. Having a meta-package for the server and not 
one for mariabackup may seem inconsistent, but users are different. A lot of 
people just want MariaDB and don't (need to) care about versions. Maybe they 
barely know SQL and just want to run a simple script. For backups, it's 
different. If you need mariabackup you manage a MariaDB instance, and you need 
to care about versions.
Federico


      Da: Florent B <flor...@coppint.com>
 A: Vladislav Vaintroub <vvaintr...@gmail.com>; 
"maria-discuss@lists.launchpad.net" <maria-discuss@lists.launchpad.net> 
 Inviato: Mercoledì 14 Febbraio 2018 12:23
 Oggetto: Re: [Maria-discuss] mariadb-backup meta deb package
   
 I'm sorry but that's what not I mean. My message was just a suggestion, to 
have a "meta-package" for Debian repository, like we have a meta-package 
"mariadb-server" that points to "mariadb-server-10.2" (for example, if you 
installed 10.2 repository). In my deployment script, I just install 
"mariadb-server", without specifying version. I would like to do the same for 
"mariadb-backup". For now, I have to specify version of package : 
mariadb-backup-10.2. It could be nice to have a "mariadb-backup" meta-package 
to point automatically to the latest version available. 
 On 14/02/2018 12:08, Vladislav Vaintroub wrote:
  
 
#yiv8725764717 #yiv8725764717 -- _filtered #yiv8725764717 {panose-1:2 4 5 3 5 4 
6 3 2 4;} _filtered #yiv8725764717 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 
3 2 4;}#yiv8725764717 #yiv8725764717 p.yiv8725764717MsoNormal, #yiv8725764717 
li.yiv8725764717MsoNormal, #yiv8725764717 div.yiv8725764717MsoNormal 
{margin:0in;margin-bottom:.0001pt;font-size:11.0pt;}#yiv8725764717 a:link, 
#yiv8725764717 span.yiv8725764717MsoHyperlink 
{color:blue;text-decoration:underline;}#yiv8725764717 a:visited, #yiv8725764717 
span.yiv8725764717MsoHyperlinkFollowed 
{color:#954F72;text-decoration:underline;}#yiv8725764717 
.yiv8725764717MsoChpDefault {} _filtered #yiv8725764717 {margin:70.85pt 70.85pt 
56.7pt 70.85pt;}#yiv8725764717 div.yiv8725764717WordSection1 {}#yiv8725764717  
The latest backup will not work with your 10.1 server. Mariabackup version 
should match server version that you have on the same box. mariabackup from 
10.1 appears to work with 5.5 and 10.0, but this is merely by luck and by 
accident.        From: Florent B
 Sent: Wednesday, February 14, 2018 11:58 AM
 To: maria-discuss@lists.launchpad.net
 Subject: Re: [Maria-discuss] mariadb-backup meta deb package     On 14/02/2018 
11:16, Reindl Harald wrote: >   >   > Am 14.02.2018 um 10:51 schrieb Florent B: 
>> Wouldn't be nice to have a metapackage mariadb-backup in Debian >> 
repository, that depends on the current best version >> (mariadb-backup-10.2, 
etc..) ? >>   >> Like "mariadb-server" package in fact >   > you missed to 
describe the problem you want to solve by step in with a > solution which is 
always the wrong start because in case you didn't > understand the real problem 
any solution is wrong    I just want to install the latest mariadb-backup 
package, without checking version by myself (10.1, 10.2...). Exactly the same 
as the "mariadb-server" metapackage for Debian, which points to latest version 
possible.    _______________________________________________ Mailing list: 
https://launchpad.net/~maria-discuss Post to     : 
maria-discuss@lists.launchpad.net Unsubscribe : 
https://launchpad.net/~maria-discuss More help   : 
https://help.launchpad.net/ListHelp     
 _______________________________________________
Mailing list: https://launchpad.net/~maria-discuss
Post to    : maria-discuss@lists.launchpad.net
Unsubscribe : https://launchpad.net/~maria-discuss
More help  : https://help.launchpad.net/ListHelp


   
_______________________________________________
Mailing list: https://launchpad.net/~maria-discuss
Post to     : maria-discuss@lists.launchpad.net
Unsubscribe : https://launchpad.net/~maria-discuss
More help   : https://help.launchpad.net/ListHelp

Reply via email to