[
http://opencast.jira.com/browse/MH-7599?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=27609#comment-27609
]
Adam Hochman commented on MH-7599:
----------------------------------
I found this not be working as well. A few questions....
Is first instance org.opencastproject.ingest.scanner.InboxScanner.properties
represent the default inbox? I kept it as is except for changing the
workflow.definition.1 but the inbox still ran the default workflow. I found
that there is a setting for default workflow in config.properties thinking that
it was possibly causing a conflict but it didn't help.
I assumed that ootb config for *InboxScanner.properties does not represent the
default inbox, because when I changed the instance path to an absolute path,
"/opt/matterhorn/felix/inbox/youtube", the /inbox path still worked. I find it
pretty confusing since there should be a way to set the workflow def and path
for the ootb inbox.
I think in Miguel's circumstance he could have put anything in
*InboxScanner.properties for the first instance and it would have worked,
because it looks the this config is simply ignored. The reason he thought his
first instance worked was because it is basically the same config as the ootb
inbox.
"workflow.definition.1=full
workflow.properties.1=trimHold=true; captionHold=false
inbox.path.1=/ "
I was also confused about the need for an additional
*fileinstall-dictionary.cfg per instance. Is there a naming convention for
this file? I added an additional one called
org.apache.felix.fileinstall-inboxcustom.cfg which contained.
felix.fileinstall.dir=./inbox/youtube
felix.fileinstall.poll=5000
I then changed my first instance to the following with no luck.
workflow.definition.1=yt
inbox.path.1=/opt/matterhorn/felix/inbox/youtube
I did find that my default workflow inbox still worked though. Thoughts?
> Multiple Inbox folder not working
> ---------------------------------
>
> Key: MH-7599
> URL: http://opencast.jira.com/browse/MH-7599
> Project: Matterhorn Project
> Issue Type: Bug
> Components: Architecture & Services
> Affects Versions: 1.1 , 1.1.1, 1.2
> Reporter: Miguel
> Priority: Critical
> Fix For: 1.3
>
>
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira
_______________________________________________
Matterhorn mailing list
[email protected]
http://lists.opencastproject.org/mailman/listinfo/matterhorn
To unsubscribe please email
[email protected]
_______________________________________________