Siebrand has uploaded a new change for review.
https://gerrit.wikimedia.org/r/97339
Change subject: Rename File::_getIsSafeFile() to getIsSafeFileUncached()
......................................................................
Rename File::_getIsSafeFile() to getIsSafeFileUncached()
Part of project to remove underscores from method names and class names.
Change-Id: I597565d87002ebc8f3d74f6428ca009e25040519
---
M includes/filerepo/file/File.php
1 file changed, 2 insertions(+), 2 deletions(-)
git pull ssh://gerrit.wikimedia.org:29418/mediawiki/core
refs/changes/39/97339/1
diff --git a/includes/filerepo/file/File.php b/includes/filerepo/file/File.php
index 8e6dc8d..85aeac0 100644
--- a/includes/filerepo/file/File.php
+++ b/includes/filerepo/file/File.php
@@ -663,7 +663,7 @@
*/
function isSafeFile() {
if ( !isset( $this->isSafeFile ) ) {
- $this->isSafeFile = $this->_getIsSafeFile();
+ $this->isSafeFile = $this->getIsSafeFileUncached();
}
return $this->isSafeFile;
@@ -683,7 +683,7 @@
*
* @return bool
*/
- protected function _getIsSafeFile() {
+ protected function getIsSafeFileUncached() {
global $wgTrustedMediaFormats;
if ( $this->allowInlineDisplay() ) {
--
To view, visit https://gerrit.wikimedia.org/r/97339
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings
Gerrit-MessageType: newchange
Gerrit-Change-Id: I597565d87002ebc8f3d74f6428ca009e25040519
Gerrit-PatchSet: 1
Gerrit-Project: mediawiki/core
Gerrit-Branch: master
Gerrit-Owner: Siebrand <[email protected]>
_______________________________________________
MediaWiki-commits mailing list
[email protected]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits