jenkins-bot has submitted this change and it was merged.
Change subject: Rename File::_getIsSafeFile() to getIsSafeFileUncached()
......................................................................
Rename File::_getIsSafeFile() to getIsSafeFileUncached()
Part of project to remove underscores from method names and class names.
Change-Id: I597565d87002ebc8f3d74f6428ca009e25040519
---
M includes/filerepo/file/File.php
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Aaron Schulz: Looks good to me, approved
jenkins-bot: Verified
diff --git a/includes/filerepo/file/File.php b/includes/filerepo/file/File.php
index 8e6dc8d..85aeac0 100644
--- a/includes/filerepo/file/File.php
+++ b/includes/filerepo/file/File.php
@@ -663,7 +663,7 @@
*/
function isSafeFile() {
if ( !isset( $this->isSafeFile ) ) {
- $this->isSafeFile = $this->_getIsSafeFile();
+ $this->isSafeFile = $this->getIsSafeFileUncached();
}
return $this->isSafeFile;
@@ -683,7 +683,7 @@
*
* @return bool
*/
- protected function _getIsSafeFile() {
+ protected function getIsSafeFileUncached() {
global $wgTrustedMediaFormats;
if ( $this->allowInlineDisplay() ) {
--
To view, visit https://gerrit.wikimedia.org/r/97339
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I597565d87002ebc8f3d74f6428ca009e25040519
Gerrit-PatchSet: 2
Gerrit-Project: mediawiki/core
Gerrit-Branch: master
Gerrit-Owner: Siebrand <[email protected]>
Gerrit-Reviewer: Aaron Schulz <[email protected]>
Gerrit-Reviewer: jenkins-bot
_______________________________________________
MediaWiki-commits mailing list
[email protected]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits