Yes, it does.

Marek

On Mar 13, 2018 10:44 PM, "Dylan Baker" <dy...@pnwbakers.com> wrote:

> Does meson need the same change?
>
> On March 13, 2018 6:03:18 PM PDT, "Marek Olšák" <mar...@gmail.com> wrote:
>>
>> From: Marek Olšák <marek.ol...@amd.com>
>>
>> Since 2.4.90 might not work, just ask for the next version.
>> ---
>>  configure.ac | 9 +--------
>>  1 file changed, 1 insertion(+), 8 deletions(-)
>>
>> diff --git a/configure.ac b/configure.ac
>> index e29ce68..8ec5b26 100644
>> --- a/configure.ac
>> +++ b/configure.ac
>> @@ -67,21 +67,21 @@ OPENCL_VERSION=1
>>  AC_SUBST([OPENCL_VERSION])
>>
>>  # The idea is that libdrm is distributed as one cohesive package, even
>>  # though it is composed of multiple libraries. However some drivers
>>  # may have different version requirements than others. This list
>>  # codifies which drivers need which version of libdrm. Any libdrm
>>  # version dependencies in non-driver-specific code should be reflected
>>  # in the first entry.
>>  LIBDRM_REQUIRED=2.4.75
>>  LIBDRM_RADEON_REQUIRED=2.4.71
>> -LIBDRM_AMDGPU_REQUIRED=2.4.90
>> +LIBDRM_AMDGPU_REQUIRED=2.4.91
>>  LIBDRM_INTEL_REQUIRED=2.4.75
>>  LIBDRM_NVVIEUX_REQUIRED=2.4.66
>>  LIBDRM_NOUVEAU_REQUIRED=2.4.66
>>  LIBDRM_FREEDRENO_REQUIRED=2.4.91
>>  LIBDRM_ETNAVIV_REQUIRED=2.4.82
>>
>>  dnl Versions for external dependencies
>>  DRI2PROTO_REQUIRED=2.8
>>  GLPROTO_REQUIRED=1.4.14
>>  LIBOMXIL_BELLAGIO_REQUIRED=0.0
>> @@ -2601,27 +2601,20 @@ if test -n "$with_gallium_drivers"; then
>>                  radeon_llvm_check $LLVM_REQUIRED_R600 "r600"
>>
>>                  llvm_add_component "asmparser" "r600"
>>                  llvm_add_component "bitreader" "r600"
>>              fi
>>              ;;
>>          xradeonsi)
>>              HAVE_GALLIUM_RADEONSI=yes
>>              PKG_CHECK_MODULES([RADEON], [libdrm >= $LIBDRM_RADEON_REQUIRED 
>> libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
>>              PKG_CHECK_MODULES([AMDGPU], [libdrm >= $LIBDRM_AMDGPU_REQUIRED 
>> libdrm_amdgpu >= $LIBDRM_AMDGPU_REQUIRED])
>> -
>> -            # Blacklist libdrm_amdgpu 2.4.90 because it breaks older 
>> radeonsi
>> -            libdrm_version=`pkg-config libdrm_amdgpu --modversion`
>> -            if test "x$libdrm_version" = x2.4.90; then
>> -                AC_MSG_ERROR([radeonsi can't use libdrm 2.4.90 due to a 
>> compatibility issue. Use a newer or older version.])
>> -            fi
>> -
>>              require_libdrm "radeonsi"
>>              radeon_llvm_check $LLVM_REQUIRED_RADEONSI "radeonsi"
>>              if test "x$enable_egl" = xyes; then
>>                  require_basic_egl "radeonsi"
>>              fi
>>              ;;
>>          xnouveau)
>>              HAVE_GALLIUM_NOUVEAU=yes
>>              PKG_CHECK_MODULES([NOUVEAU], [libdrm >= 
>> $LIBDRM_NOUVEAU_REQUIRED libdrm_nouveau >= $LIBDRM_NOUVEAU_REQUIRED])
>>              require_libdrm "nouveau"
>>
>>
_______________________________________________
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev

Reply via email to