I am having trouble updating MiKTex 2.9 on a Windows 10 system, and I'm hoping 
someone on this list can help me.

I've tried both using the update wizard in the MPM interface and running update 
from the command line. When I run the update wizard, I get an error message 
that says this:

Sorry, but something went wrong

The executed process did not succeed.

fileName=''C:\Program Files\MiKTeX 2.9\miktex\bin\x64\initexmf.exe'', 

The error log includes this line:

2018-01-04 11:04:54,454-0500 INFO FileCopyPage - initexmf: warning: The link 
target "C:\Program Files\MiKTeX 2.9\miktex/bin/x64\miktex-pdfsig.exe" does not 

I've searched and I don't seem to have miktex-pdfsig.exe anywhere on my system. 
It also doesn't seem to be part of the MiKTeX 2.9 distribution. At least it 
doesn't appear here:


When I run from the command line I get this:

Sorry, but "MiKTeX Package Manager" did not succeed.

The log file hopefully contains the information to get MiKTeX going again:


You may want to visit the MiKTeX project page, if you need help.

With this message in the log:

2018-01-04 15:11:34,712-0500 FATAL mpmcli - MiKTeX encountered an internal 

2018-01-04 15:11:34,713-0500 FATAL mpmcli - Info: keyName="amscls"

2018-01-04 15:11:34,713-0500 FATAL mpmcli - Source: 

2018-01-04 15:11:34,713-0500 FATAL mpmcli - Line: 750

The reason I'm trying to run the update is that the MiKTeX installation gave me 
Biber version 2.7 but Biblatex version 3.10, so I need to update Biber to 2.10 
to get them to work together. I've tried reinstalling with windows defender not 
checking the MiKTeX folder and got the same results.

Thanks for any help you can give,


Prof. J. Robert Loftis
Division of Arts and Humanities.
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Q: How can I leave the mailing list?
A: See http://docs.miktex.org/faq/support.html#leavingml

Reply via email to