There seems to have been an unpleasant change in the default configuration.

Occasionally, I have to write things in Russian. For an obvious
compatibility reason, I prefer to keep my files in the plain text format,
switching to the CP1251 in the editors and relying upon TeX and Babel that
do the job perfectly well. Last time I did that (a few months ago)
everything was perfect: the file was ASCII while WinEdt was showing it with
the correct codepage. However, today, when I tried to open one of the old
files, changed CP to 1251 and hit "Reload", I got a mess like this: 
\`{A}\^{a}\`{o}\^{\i}р \`{e}\c{c}\'{o}ч\`{a}{\aa}\`{o} \`{o}р\`{e} ...
This has obviously something to do with the TeX settings, as I have recently
tried to use WinEdt to recode other (non TeX) files to Unicode and
everything worked well. A quick check shows that I don't have any unusual
read/write translation tables enabled except the most common ones, with
accented Latin characters (which would be supposed to work the opposite way
anyway). If I just load the file without changing the CP (or open it in
notepad), it looks like a typical Russian text in the Latin codepage, as
it's supposed to.

So, to make my complaint clear, I want to keep an ASCII TeX-file on the disk
and edit it in a codepage of my choice. Alex, how can I fix this? And,
please, don't make such drastic changes without announcing them in bold red
font next to the download link!

Best regards,

P.S. Some other things have been broken, too. E.g., it appears that the new
compilation script does not call the old one, so the automatic format
detection has been broken and, apparently, has to be rewritten from the
scratch. But this I can live with...

Check out the vibrant tech community on one of the world's most
engaging tech sites,!
Q: How can I leave the mailing list?
A: See

Reply via email to