On Wed, 8 Jul 2026, Jacek Caban via Mingw-w64-public wrote:

---
mingw-w64-crt/Makefile.am | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)

The commit subject is a bit weirdly worded - perhaps s/with// makes it more readable?

@@ -25,6 +25,12 @@ AM_CXXFLAGS=@ADD_C_CXX_WARNING_FLAGS@ 
@ADD_CXX_ONLY_WARNING_FLAGS@
AM_CCASFLAGS=@CFGUARD_CFLAGS@
CPPFLAGSARM32=$(AM_CPPFLAGS) -mfpu=vfpv3
CPPFLAGSARM64=$(AM_CPPFLAGS)
+CPPFLAGSARM64NATIVE=$(AM_CPPFLAGS)
+CPPFLAGSARM64EC=$(AM_CPPFLAGS)
+if ARM64X
+    CPPFLAGSARM64 += -marm64x
+    CPPFLAGSARM64EC += -target arm64ec-windows-gnu
+endif

This commit is a bit weirdly split, as there's nothing using the CPPFLAGSARM64EC variable yet at this point. It would perhaps be more understandable if adding that variable would be left to the next commit.

Passing -marm64x through CPPFLAGSARM64 feels a bit weird, as this isn't a C preprocessor flag (I presume passing "clang -E -marm64x" doesn't really do anything special). But I guess it's the most suitable makefile variable we have already...

// Martin



_______________________________________________
Mingw-w64-public mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/mingw-w64-public

Reply via email to