On 7/8/26 23:24, Martin Storsjö wrote:
On Thu, 9 Jul 2026, Martin Storsjö wrote:


diff --git a/mingw-w64-crt/configure.ac b/mingw-w64-crt/configure.ac
index 1f1c11eb6..5e5d2f7f3 100644
--- a/mingw-w64-crt/configure.ac
+++ b/mingw-w64-crt/configure.ac
@@ -170,6 +170,18 @@ AS_VAR_IF([enable_libarm64],[yes],[
  AS_IF([AS_VAR_TEST_SET([LIB32]) || AS_VAR_TEST_SET([LIB64]) || AS_VAR_TEST_SET([LIBARM32])],     [AC_MSG_WARN([Building the runtime to use libarm64 with lib32, lib64 or libarm32 is unsupported.])])])

+AC_MSG_CHECKING([whether to build the ARM64EC libraries])
+AC_ARG_ENABLE([arm64ec],
+  [AS_HELP_STRING([--enable-arm64ec], [Build the ARM64EC libraries])],

The option description makes this a little bit confusing, as you don't need to set this when configuring with --host=arm64ec-... And "the arm64ec libraries" also sounds vague, what are they? As we produce the exact same set of files as before...

"Include arm64ec specific files even if building for another architecture" is specific, but also sounds very weird if one isn't familiar with the setup.

In one sense, the option you'd want is --enable-arm64x, which would both include the files, and implicitly add -marm64x to cflags. But there are merits to having the two aspects separated like this too.

+  [yes],[AS_VAR_SET([ARM64X])],
+  [AC_MSG_ERROR([invalid argument.  Must be either yes or no.])])
+AM_CONDITIONAL([ARM64X], [AS_VAR_TEST_SET([ARM64X])])

I overlooked this part in this commit - and now also later noticed that commit 2 adds -marm64x.

With that in mind, I definitely think the option should be named --enable-arm64x, not --enable-arm64ec, and the option description can be twekaed with that in mind. Since the regular separate-architecture mode of arm64ec still is an entirely valid way of doing it (even if we might not want to actually test build that in the long run).


Sure, I'll change it. I originally named it --enable-arm64x, but then thought that at some point, it will hopefully be the go-to option, even for someone who is interested in arm64ec itself rather than arm64x. I don't have a strong opinion, though, so I'll change it back.


Thanks,

Jacek



_______________________________________________
Mingw-w64-public mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/mingw-w64-public

Reply via email to