On Thu, Feb 16, 2017 at 08:46:45AM +0100, Raimo Niskanen wrote:
> Hello Misc@
> 
> I tried to activate ypbind via rcctl:
>     rcctl enable ypbind
> and it did not write "ypbind_flags=" into /etc/rc.conf.local.
> 
> I had run ypbind so it should start according to the documentation since
> there is a domain file in /var/yp/binding/ but when booting the machine
> ypbind did not start and there was no printout from /etc/rc about starting
> it.  "rcdctl ls failed" did print ypbind.
> 
> I tried to debug rcctl with little success.  Looking at the script it seems
> to me that it checks /etc/rc.conf and /etc/rc.conf.local and should write a
> line "ypbind_flags=" into /etc/rc.conf.local since the default in
> /etc/rc.conf is "ypbind_flags=NO".  But ktrace:ing it indicates that it
> also checks domainname and /var/yp/binding so it is smarter than it looks.
> 
> Unfortunately /etc/rc starts ypbind like any other daemon so ypbind_flags
> has to be != NO and therefore it is not started.
> 
> So there seems to be some misunderstanding between /etc/rc and rcctl about
> exactly when ypbind is enabled or not.
> 
> The workaround is easy enough (manually editing /etc/rc.conf.local so no
> big issue.
> 
> Also, I tried to set nfsd flags:
>     rcctl enable nfsd
>     rcctl set nfsd flags -tun 4
> or
>     rcctl set nfsd flags "-tun 4"
> but it did not work (nfsd_flags=)
>     rcctl set nfsd flags -tu
> did work, though.
> 
> Known problems?

It's default value, so maybe it cleaned. It was removed from FAQ just
couple of minutes/hours ago.

j.

Reply via email to