Hi Carolyn,

I had the same behavior when I tried this on -current but it was working well 
as supposed on -stable

Thus, my first thought was that the current version of the GnuPG 2 package was 
the culprit, but to be sure I tried to see if I could access the smartcard to 
discard first the drivers. So I installed the pcsc-tools package and tried to 
scan the smartcard:

  $ pcsc_scan
  PC/SC device scanner
  SCardEstablishContext: Service not available.

Now the error was clear, the pcscd daemon wasn't running. The solution was 
easy, enable it and start it:

  # rcctl enable pcscd
  # rcctl start pcscd

And that's it! You need the ccid and pcsc-tools packages installed in order to 
use a smartcard.

P.S. Anyway, both of us could have saved time and troubles if we had read the 
readme file of the package in 


where exactly this is explained and also there is an example with a Yubikey. My 
bad, I'm starting with OpenBSD coming from a looong time on Linux  and I don't 
know all the OB' bolts and nuts yet ;)


El 7 de agosto de 2017 7:09:32 CEST, Carolyn Saunders <gigavi...@gmail.com> 
>I have a Yubikey that I'd like to use for gpg and ssh purposes. Running
>"gpg --card-status" works as expected; it brings up the various keys
>attached to the device and other information. However, running "gpg2
>--card-status" just hangs, seemingly forever. What am I missing here?
>Thanks :)

Reply via email to