[2024-04-16 14:49] Lévai, Dániel <l...@ecentrum.hu>
> On Tuesday, April 16th, 2024 at 13:52, Philipp <phil...@bureaucracy.de> wrote:
> > [2024-04-15 10:11] Lévai, Dániel l...@ecentrum.hu
> > 
> > > I've been using this Samsung C480FW printer/scanner forever with 
> > > OpenSMTPD and suddenly (no upgrades to OpenSMTPD or changes in the
> > > configuration) it started to complain (it's trying to send scanned 
> > > documents via e-mail):
> > 
> > 
> > Has something on the scanner changed? Like a firmwareupdate or changed
> > settings. Something must have changed, when it has worked and now it
> > doesn't work anymore.
> Yeah I know it's always suspicious when someone says "nothing changed" :)
> Really nothing changed on the smtpd server or the printer.
> The last successful scan was from the 12th of April and the next time I tried 
> on the 15th it failed. Today, all of them succeeded ag
> ain.
> I suspect it depends on the content of the message, somehow - as the only 
> variable is the actual document I'm scanning. 
> Idk, probably some weird characters, spacing or weird lines - I know, at this 
> point it just sounds sorcery.
> Anyway, I was just wondering if there was an option to somehow relax some 
> checks, but I can live with retrying until it succeeds.

As said in the other mail no there is no such option. Such an option
would cause problems in other programms when they try to parse the mail.

> > > It's somewhere after DATA smtpd doesn't like what it's seeing.
> > 
> > Actually I don't see why this message is not accepted. Only think I can
> > imagen is that the Content-features field is not properly folded. So that
> > the character used to indent is not WSP (space or horizontal tab). But
> > this is only a guess.
> I have the same suspicion (or let's call it feeling), but can't reproduce 
> this willingly, unfortunately.
> > The attached patch adds a few more tracing information for the parser. Can
> > you apply this patch and try again?
> I've applied it to OpenBSD 7.4. The only thing I can reproduce this with 
> reliably is the SMTP test function on the printer admin page - so this is not 
> an actual scanned document e-mail that is sometimes failing:

Looking at the new trace I see the reason[0] for the error. Other then
I supected it's the body seperator, which does in your case start with
a WSP. A wild guess is that the boundery parameter of the working mails
contain ':'.

A workaround for your problem would be a filter which detects these
mails and remove the WSP from the body seperator. But be carefull with
such a filter, because it might break other mails quite easy. So make
sure you only make changes to mails from your scanner.


[0] besides my inability to copy paste variables

Reply via email to