Hi Peter,

> Am 25.09.2015 um 17:32 schrieb Peter Levart <peter.lev...@gmail.com>:
>> One question about MethodType: would you mind doing something about the 
>> naming of the newly introduced fromDescriptor() method? Its name does not 
>> suggest in any way that it chooses the class loader differently. The name is 
>> subtly different from that of fromDescriptorString(), and the signature is 
>> identical - it's probably really easy to confuse the two when working at the 
>> core libs level. Unfortunately, the only proposal for a name I can make, 
>> fromDescriptorStringBootCL(), is clunky. Maybe that's acceptable for a 
>> low-level method only visible at package level.
> Well, the correct self-describing name would then be 
> fromDescriptorStringNullIsBootstrapCL()...

yes ... or the entire source code in camel case. ;-) I see your point, and 
wasn't happy with my original proposal either.

> Perhaps a note in the javadoc that this is the preferred method for internal 
> use would be sufficient? We can't make a reference from public method to the 
> package-private one in javadoc though.

That's a good idea.




Dr. Michael Haupt | Principal Member of Technical Staff
Phone: +49 331 200 7277 | Fax: +49 331 200 7561
Oracle Java Platform Group | LangTools Team | Nashorn
Oracle Deutschland B.V. & Co. KG, Schiffbauergasse 14 | 14467 Potsdam, Germany
 <http://www.oracle.com/commitment>     Oracle is committed to developing 
practices and products that help protect the environment

mlvm-dev mailing list

Reply via email to