I came across this thread because my Mnemosyne was crashing (segfault) on 
editing cards. I am on macOS 10.13.3, using 2.6 it segfaults when I try to edit 
an entry. (Just using it to memorize and score works fine, funnily enough 
adding new cards works too.)
So I tested with 2.6-qt5.10 version, this one does not segfault but shows a way 
too big editing popup window with garbage white/grey stripes = editing does not 
work but app stays alive.

This is happening with a selfmade DB french/german vocabulary that grew to 1300 
entries over the last 6month. After export in v2.x cards format and re-import 
(losing my scoring though) everything works fine again. I can send my 
segfault-causing ~/Libary/Mnemosyne folder if that helps.


Am Montag, 12. Februar 2018 14:34:56 UTC+1 schrieb Dan Schmidt:
> Some more data: this morning I was suddenly unable to run Mnemosyne at all 
> (macOS 10.13.3, upgraded from Sierra to High Sierra a few weeks ago but had 
> been running every day since). I would get a "Trace/BPT trap: 5" error that 
> appeared to be happening inside Qt from the stack trace. I had a few old 
> versions of Mnemosyne so I tried those; 2.4 had the same problem but 2.3.6 
> ran okay.
> I came to this group and discovered 2.6-qt5.10, which seems to be running 
> fine (though as you say the style has changed somewhat). Thanks for that, and 
> let me know if I can add any more useful information.
> Dan
> On Monday, February 5, 2018 at 10:43:21 PM UTC-5, Devin Howard wrote:
> Hi Emily
> I'm not really sure what the problem is, but I tried making a special build 
> of Mnemosyne 2.6 just for macOS that uses a newer version of some internal 
> software ("qt 5.10")
> You can find Mnemosyne-2.6-qt5.10.dmg at 
> https://sourceforge.net/projects/mnemosyne-proj/files/mnemosyne/mnemosyne-2.6/.
>  It looks a little old fashioned for some reason, and it might have different 
> bugs, but it's possible it will fix your issue. Stranger things have happened!
> Try it out and let me know if it works for you. You should be safe to switch 
> between the Mnemosyne-2.6 app and the Mnemosyne-2.6-qt5.10 app if you don't 
> like the new version.
> On Monday, January 22, 2018 at 6:29:42 PM UTC-8, Devin Howard wrote:
> Hi, I tried this out on my machine and I wasn't able to see an error.
> Could you directly email me your database files so I can try with your set of 
> cards? It should be everything under /Users/<your username>/Library/Mnemosyne
> If you send me that, perhaps I'll be able to find out what the issue is. 
> As Peter said, it would also be interesting to know what version of macOS you 
> are running (which you can find under "About this Mac" in the main apple 
> menu).
> On Friday, January 19, 2018 at 9:45:55 PM UTC-8, Emily Ritter wrote:Hello, 
> yesterday I tried to download the new version of Mnemosyne and now I am no 
> longer able to open the new one or the old one. I have a Macbook pro and 
> every time I try to open either one, a notification comes up saying that 
> Mnemosyne has quit unexpectedly. I had about 1000 flashcards on the original 
> app and I haven't backed them up so I was really hoping there was some way I 
> could access them again without losing my data! Thank you!
> Emily

You received this message because you are subscribed to the Google Groups 
"mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to mnemosyne-proj-users+unsubscr...@googlegroups.com.
To post to this group, send email to mnemosyne-proj-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to