Hi group,

I'm trying to run mod_fcgid with custom suexec and fcgiwrapper.

I have it running without the  suexec, but when I get to this point I'm
debugging for over a week.
The main problem is that if I run mod_fcgid with original apache suexec
it works,
as expected,
If I'm using _custom_ written from scratch suexec that makes chroot and
chuid/gid it won't work.
The problem appears when I enable it, the php is saying 'no input file
I can't understand how the file/dir(php script) to be run from the php
interpretator is passed.
If I run apache+custom suexec(no mod_fcgid) I have DOCUMENT_ROOT and
and that's how php knows where to look for the php file(eventually if
not passed as argument which file to run as 3rd param to suexec).
As far as I saw when mod_fcgid calls suexec the third param is
fcgiwrapper file and no 4th param is passed(which file to run?),
no DOCUMENT_ROOT and SCRIPT_NAME is set too, so it's understandable that
php can't find/exec .php file...

Can anyone help me what should I do in my suexec (I use execve(argv[3],
*argv, enviorn) to exec the script wrapper);
Please give me any ideas, hints because I'm desperate!
If more info is needed pls tell me.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
Mod-fcgid-users mailing list

Reply via email to