On Wed, Mar 24, 2010 at 7:56 AM, T_ S_ <li...@ruby-forum.com> wrote:
> I added memcache-client to our app:
> config.gem "memcache-client", :version => "1.8.1"
> According to "gem list" the gem is there:
> memcache-client (1.8.1)
> If I run our app with "script/server" everything works just fine but
> when I try to run it with "mongrel_rails start" it stops with error:
> no such file to load -- memcache-client
> So is there something different how mongrel_rails looks up gems? What is
> so special about this gem as the other gems work just fine?

When you start mongrel_rails, you're doing without daemonize, correct?

There is no configuration file that indicates mongrel should change
user or group when running, correct?

It might be that the memcache-client gem is not installed system wide.

I've used mongrel_rails, combined with memcache-client and memcached
in a bundler configuration and worked without issues, so the problem
might be something else.

Can you build an exact pastie/gist of the output you're receiving? (or
can replicate with a simple rails app?)

Thank you
Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry
Mongrel-users mailing list

Reply via email to