>From previous conversation:

On Oct 18, 2016 9:08 AM, "Marek Safar" <marek.sa...@gmail.com> wrote:

Yes, please

On Tue, Oct 18, 2016 at 3:53 PM, Cyd Haselton <chaselton
<chasel...@gmail.com>@gmail.com <chasel...@gmail.com>>wrote:

I've already posted full build logs from root source folder.  Do you want
me to also cd to mono, run make and post build logs from that?

I posted full build logs about four replies back; here are the links:

autogen.sh:http://pastebin.com/P4LcBWpZ
make: http://pastebin.com/JvdhWhCC

On Oct 18, 2016 1:23 PM, "Marek Safar" <marek.sa...@gmail.com> wrote:

> I asked for "full mono build" not for build of mono subfolder
>
> On Tue, Oct 18, 2016 at 6:17 PM, Cyd Haselton <chasel...@gmail.com> wrote:
>
>> That's it. You asked me to build in the mono directory…that's the result.
>> When I go back and build in the root source directory it fails with the
>> same error as you saw in the full build log
>>
>> On Oct 18, 2016 10:38 AM, "Marek Safar" <marek.sa...@gmail.com> wrote:
>>
>>> and then it stopped or where is the rest of the build output?
>>>
>>> On Tue, Oct 18, 2016 at 5:29 PM, Cyd Haselton <chasel...@gmail.com>
>>> wrote:
>>>
>>>> Build in mono dir completed successfully
>>>>
>>>> Link to logs: http://pastebin.com/2YwrnFCe
>>>>
>>>> On Oct 18, 2016 10:05 AM, "Cyd Haselton" <chasel...@gmail.com> wrote:
>>>>
>>>>> That's just it; it doesn't fail.  I'll post the pastebin links when I
>>>>> have them.
>>>>>
>>>>> On Oct 18, 2016 10:02 AM, "Marek Safar" <marek.sa...@gmail.com> wrote:
>>>>>
>>>>>> I'd like to see full mono build wherever it fails, just gist that.
>>>>>>
>>>>>> On Tue, Oct 18, 2016 at 4:53 PM, Cyd Haselton <chasel...@gmail.com>
>>>>>> wrote:
>>>>>>
>>>>>>> The build fails at the end because of a dependency on libeglib, so I
>>>>>>> have to cd to eglib and build there as well. Do you want logs from that
>>>>>>> build too?
>>>>>>>
>>>>>>> On Oct 18, 2016 9:08 AM, "Marek Safar" <marek.sa...@gmail.com>
>>>>>>> wrote:
>>>>>>>
>>>>>>>> Yes, please
>>>>>>>>
>>>>>>>> On Tue, Oct 18, 2016 at 3:53 PM, Cyd Haselton <chasel...@gmail.com>
>>>>>>>> wrote:
>>>>>>>>
>>>>>>>>> I've already posted full build logs from root source folder.  Do
>>>>>>>>> you want me to also cd to mono, run make and post build logs from 
>>>>>>>>> that?
>>>>>>>>>
>>>>>>>>> On Oct 18, 2016 8:30 AM, "Marek Safar" <marek.sa...@gmail.com>
>>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>>> You should not be using make within mcs/mcs if you haven't
>>>>>>>>>> compiled mono successfully before that. Start from scratch and paste 
>>>>>>>>>> full
>>>>>>>>>> log when building from root mono folder.
>>>>>>>>>>
>>>>>>>>>> On Tue, Oct 18, 2016 at 3:20 PM, Cyd Haselton <
>>>>>>>>>> chasel...@gmail.com> wrote:
>>>>>>>>>>
>>>>>>>>>>> Thanks Marek,
>>>>>>>>>>> Any input on the logs?
>>>>>>>>>>>
>>>>>>>>>>> In the meantime I've deleted the build tree and re-downloaded
>>>>>>>>>>> the sources so that I can start over from scratch.
>>>>>>>>>>>
>>>>>>>>>>> Don't know if this is relevant but I have noticed that the
>>>>>>>>>>> Makefiles and various other scripts do not pick up the CONFIG_SHELL 
>>>>>>>>>>> and
>>>>>>>>>>> SHELL vars that I specify when running the top-level configure 
>>>>>>>>>>> and/or
>>>>>>>>>>> autogen.sh.  Instead they default to /bin/sh, which will definitely 
>>>>>>>>>>> error
>>>>>>>>>>> out on my platform.  I've patched as many of the offending files 
>>>>>>>>>>> I've found.
>>>>>>>>>>>
>>>>>>>>>>> On Oct 18, 2016 7:54 AM, "Marek Safar" <marek.sa...@gmail.com>
>>>>>>>>>>> wrote:
>>>>>>>>>>>
>>>>>>>>>>>> No, bootstrap process is not deprecated and it's still actively
>>>>>>>>>>>> used especially when system mono is unavailable or too old.
>>>>>>>>>>>>
>>>>>>>>>>>> Marek
>>>>>>>>>>>>
>>>>>>>>>>>> On Tue, Oct 18, 2016 at 12:23 PM, Cyd Haselton <
>>>>>>>>>>>> chasel...@gmail.com> wrote:
>>>>>>>>>>>>
>>>>>>>>>>>>> Ping for any input on pastebin logs (see previous emails) and
>>>>>>>>>>>>> if bootstrapping mcs was/is/will be deprecated.
>>>>>>>>>>>>>
>>>>>>>>>>>>> On Oct 16, 2016 2:28 PM, "Cyd Haselton" <chasel...@gmail.com>
>>>>>>>>>>>>> wrote:
>>>>>>>>>>>>>
>>>>>>>>>>>>>> Still troubleshooting, though I'm running out of ideas.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Is it possible bootstrapping mcs was deprecated?
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> On Oct 15, 2016 6:52 PM, "Cyd Haselton" <chasel...@gmail.com>
>>>>>>>>>>>>>> wrote:
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> I blew away the build directory, downloaded the 10/13
>>>>>>>>>>>>>>> tarball from mono/sources (http://download.mono-project.
>>>>>>>>>>>>>>> com/sources/mono/nightly/) and started over from scratch.
>>>>>>>>>>>>>>> I got the same error that you can see in the pastebin log; 
>>>>>>>>>>>>>>> something in the
>>>>>>>>>>>>>>> build is expecting mscorlib.dll to be installed at 
>>>>>>>>>>>>>>> usr/lib/mono/4.5.
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Just for kicks I created the usr/lib/mono/4.5 directory and
>>>>>>>>>>>>>>> softlinked mscorlib.dll to that location. The build progresses, 
>>>>>>>>>>>>>>> then fails
>>>>>>>>>>>>>>> with the dreaded Mono.CSharp.InternalErrorException error.
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> After that error I navigated to mcs/mcs, ran make and got an
>>>>>>>>>>>>>>> error that the build 'cannot find ./../mcs/class/lib/mcs.exe.'  
>>>>>>>>>>>>>>> Which is
>>>>>>>>>>>>>>> odd because the build shouldn't be using mcs.exe; it isn't 
>>>>>>>>>>>>>>> installed on my
>>>>>>>>>>>>>>> system.
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Pastebin of mcs/mcs make errors here:
>>>>>>>>>>>>>>> http://pastebin.com/mxBLYmnH
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Thanks,
>>>>>>>>>>>>>>> Cyd
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> On Oct 15, 2016 2:42 PM, "Cyd Haselton" <chasel...@gmail.com>
>>>>>>>>>>>>>>> wrote:
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> I can't ignore the error as it stops the build completely.
>>>>>>>>>>>>>>>> Key note: I do not have a working mcs; I'm using the
>>>>>>>>>>>>>>>> monolite bootstrap method. In this case, mscorlib.dll…along 
>>>>>>>>>>>>>>>> with other
>>>>>>>>>>>>>>>> files…IS located at mcs/class/lib/monolite
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> Here are the requested logs:
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> autogen.sh: http://pastebin.com/P4LcBWpZ
>>>>>>>>>>>>>>>> make: http://pastebin.com/JvdhWhCC
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> Additionally, here's a pastebin of the list of files in the
>>>>>>>>>>>>>>>> ./mcs/class/lib/monolite directory:
>>>>>>>>>>>>>>>> http://pastebin.com/ZcLLwWHz
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> Thanks,
>>>>>>>>>>>>>>>> Cyd
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> On Oct 14, 2016 6:17 PM, "Alexander Köplinger" <
>>>>>>>>>>>>>>>> alk...@microsoft.com> wrote:
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> That is just the default message that is compiled into the
>>>>>>>>>>>>>>>>> runtime, you can ignore it. The MONO_PATH env variable 
>>>>>>>>>>>>>>>>> controls where Mono
>>>>>>>>>>>>>>>>> tries to locate the framework assemblies in this case.
>>>>>>>>>>>>>>>>> It is weird though that this is set to
>>>>>>>>>>>>>>>>> /class/lib/monolite, no wonder it can’t find mscorlib.dll 
>>>>>>>>>>>>>>>>> there.
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> Can you please share the full build log including
>>>>>>>>>>>>>>>>> autogen.sh/configure invocations and so on in a gist or
>>>>>>>>>>>>>>>>> pastebin?
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> Thanks,
>>>>>>>>>>>>>>>>> Alex
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> On 15 Oct 2016, at 01:07, Cyd Haselton <
>>>>>>>>>>>>>>>>> chasel...@gmail.com> wrote:
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> So I scrapped everything and downloaded a newer snapshot
>>>>>>>>>>>>>>>>> from the mono/sources site.
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> This time I can't seem to bootstrap the mcs build; the
>>>>>>>>>>>>>>>>> runtime appears to be hardcoded to check for the mscorlib.dll 
>>>>>>>>>>>>>>>>> file in
>>>>>>>>>>>>>>>>> $PREFIX/lib/mono/4.5 instead of in the monolite directory.
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> make[2]: Leaving directory '/data/data/com.termux/files/p
>>>>>>>>>>>>>>>>> kg/ps/mono-4.9.0/data'             Making all in
>>>>>>>>>>>>>>>>> runtime
>>>>>>>>>>>>>>>>>                                                 make[2]:
>>>>>>>>>>>>>>>>> Entering directory '/data/data/com.termux/files/p
>>>>>>>>>>>>>>>>> kg/ps/mono-4.9.0/runtime'         if test -w
>>>>>>>>>>>>>>>>> /data/data/com.termux/files/pkg/ps/mono-4.9.0/mcs; then
>>>>>>>>>>>>>>>>> :; else chmod -R +w 
>>>>>>>>>>>>>>>>> /data/data/com.termux/files/pkg/ps/mono-4.9.0/mcs;
>>>>>>>>>>>>>>>>> fi                                            cd
>>>>>>>>>>>>>>>>> /data/data/com.termux/files/pkg/ps/mono-4.9.0/mcs && make
>>>>>>>>>>>>>>>>> --no-print-directory -s NO_DIR_CHECK=1 
>>>>>>>>>>>>>>>>> PROFILES='binary_reference_assemblies
>>>>>>>>>>>>>>>>> net_4_x xbuild_12 xbuild_14      ' CC='gcc -fPIC -fPIE'
>>>>>>>>>>>>>>>>> all-profiles
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> MONO_PATH=/class/lib/monolite: /data/data/com.termux/files/pk
>>>>>>>>>>>>>>>>> g/ps/mono-4.9.0/runtime/mono-wrapper
>>>>>>>>>>>>>>>>> .//class/lib/monolite/basic.ex
>>>>>>>>>>>>>>>>> e
>>>>>>>>>>>>>>>>> The assembly mscorlib.dll was not found or could not be
>>>>>>>>>>>>>>>>> loaded.                             It should have been
>>>>>>>>>>>>>>>>> installed in the 
>>>>>>>>>>>>>>>>> `/data/data/com.termux/files/usr/lib/mono/4.5/mscorlib.dll'
>>>>>>>>>>>>>>>>> directory.
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> Any thoughts?
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>> On Oct 12, 2016 5:15 PM, "Cyd Haselton" <
>>>>>>>>>>>>>>>>> chasel...@gmail.com> wrote:
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>> Hello Alex,
>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>> I'm not building from git-master or git; I am using
>>>>>>>>>>>>>>>>>> monolite.  I think I mentioned this earlier…if not, 
>>>>>>>>>>>>>>>>>> apologies for leaving
>>>>>>>>>>>>>>>>>> out important info.
>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>> I've gotten past the SIGSEGV I mentioned earlier by
>>>>>>>>>>>>>>>>>> editing threads.c (see https://github.com/mono/mono/c
>>>>>>>>>>>>>>>>>> ommit/1c9e34cce5e53ec5126d546a3014bc1493425219
>>>>>>>>>>>>>>>>>> <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fmono%2Fmono%2Fcommit%2F1c9e34cce5e53ec5126d546a3014bc1493425219&data=01%7C01%7Calkpli%40microsoft.com%7C2c904d06ed0b493c8c2408d3f486d145%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=KTOG36Nl3QmmRzsW%2FIQQ17R5b6NBwBw%2FI3BDy170x4c%3D&reserved=0>).
>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>> I've run into a new error that seems to occur in sgen.
>>>>>>>>>>>>>>>>>> I'm going to try building without it enabled.
>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>> Cyd
>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>> On Oct 12, 2016 1:16 PM, "Alexander Köplinger" <
>>>>>>>>>>>>>>>>>> alk...@microsoft.com> wrote:
>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>> If you don’t have a working Mono installed on your
>>>>>>>>>>>>>>>>>>> system for bootstrapping then the recommended way is to use 
>>>>>>>>>>>>>>>>>>> monolite if you
>>>>>>>>>>>>>>>>>>> build from git master: https://github.com/mon
>>>>>>>>>>>>>>>>>>> o/mono#if-you-dont-have-a-working-mono-installation
>>>>>>>>>>>>>>>>>>> <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fmono%2Fmono%23if-you-dont-have-a-working-mono-installation&data=01%7C01%7Calkpli%40microsoft.com%7C2c904d06ed0b493c8c2408d3f486d145%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=f5%2FGyZF%2BpjvWB2gqMjc%2FcVZgKjaRDU%2BY0grT0HwFAWk%3D&reserved=0>
>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>> - Alex
>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>> On 12 Oct 2016, at 20:02, Cyd Haselton <
>>>>>>>>>>>>>>>>>>> chasel...@gmail.com> wrote:
>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>> Hello Ludovic,
>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>> Would the missing 'last' field cause the SIGSEGV?
>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>> Cyd
>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>> On Oct 12, 2016 12:18 PM, "Cyd Haselton" <
>>>>>>>>>>>>>>>>>>> chasel...@gmail.com> wrote:
>>>>>>>>>>>>>>>>>>> >
>>>>>>>>>>>>>>>>>>> > Full output of './mono/mini/mono -V' here:
>>>>>>>>>>>>>>>>>>> http://pastebin.com/xZw3qhVD
>>>>>>>>>>>>>>>>>>> <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fpastebin.com%2FxZw3qhVD&data=01%7C01%7Calkpli%40microsoft.com%7C4f1712aba12141771e4008d3f2c9fd2e%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=rL8nuhHORHneIWc3OgllqTo2iB7RdN8P5YdOU2jNPpo%3D&reserved=0>
>>>>>>>>>>>>>>>>>>> >
>>>>>>>>>>>>>>>>>>> >
>>>>>>>>>>>>>>>>>>> > On Oct 12, 2016 12:12 PM, "Cyd Haselton" <
>>>>>>>>>>>>>>>>>>> chasel...@gmail.com> wrote:
>>>>>>>>>>>>>>>>>>> >>
>>>>>>>>>>>>>>>>>>> >> Since I don't have a working mcs installed, I'm using
>>>>>>>>>>>>>>>>>>> the snapshots available from the download site here:
>>>>>>>>>>>>>>>>>>> http://download.mono-project.com/sources/mono/
>>>>>>>>>>>>>>>>>>> <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fdownload.mono-project.com%2Fsources%2Fmono%2F&data=01%7C01%7Calkpli%40microsoft.com%7C4f1712aba12141771e4008d3f2c9fd2e%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=T%2BA5GezSev7nlwMowcNsMGaftco014weAy31yrfIRbM%3D&reserved=0>
>>>>>>>>>>>>>>>>>>> >>
>>>>>>>>>>>>>>>>>>> >> Here's the output of ./mono/mini/mono -V from my
>>>>>>>>>>>>>>>>>>> build tree:
>>>>>>>>>>>>>>>>>>> >>
>>>>>>>>>>>>>>>>>>> >> ./mono/mini/mono -V
>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>> >> Mono JIT compiler version 4.7.0 (Nightly
>>>>>>>>>>>>>>>>>>> 4.7.0.593/4e441ec
>>>>>>>>>>>>>>>>>>> >>
>>>>>>>>>>>>>>>>>>> >>
>>>>>>>>>>>>>>>>>>> >> On Oct 11, 2016 10:06 AM, "Ludovic Henry" <
>>>>>>>>>>>>>>>>>>> luhe...@microsoft.com> wrote:
>>>>>>>>>>>>>>>>>>> >>>
>>>>>>>>>>>>>>>>>>> >>> Hi Cyd,
>>>>>>>>>>>>>>>>>>> >>>
>>>>>>>>>>>>>>>>>>> >>>
>>>>>>>>>>>>>>>>>>> >>>
>>>>>>>>>>>>>>>>>>> >>> Which mono commit are you based on? It seems like
>>>>>>>>>>>>>>>>>>> the managed System.Threading.InternalThread is missing
>>>>>>>>>>>>>>>>>>> the “last” field.
>>>>>>>>>>>>>>>>>>> >>>
>>>>>>>>>>>>>>>>>>> >>>
>>>>>>>>>>>>>>>>>>> >>>
>>>>>>>>>>>>>>>>>>> >>> Thank you,
>>>>>>>>>>>>>>>>>>> >>>
>>>>>>>>>>>>>>>>>>> >>> Ludovic
>>>>>>>>>>>>>>>>>>> >>>
>>>>>>>>>>>>>>>>>>> >>>
>>>>>>>>>>>>>>>>>>> >>>
>>>>>>>>>>>>>>>>>>> _______________________________________________
>>>>>>>>>>>>>>>>>>> Mono-devel-list mailing list
>>>>>>>>>>>>>>>>>>> Mono-devel-list@lists.dot.net
>>>>>>>>>>>>>>>>>>> https://na01.safelinks.protect
>>>>>>>>>>>>>>>>>>> ion.outlook.com/?url=http%3A%2
>>>>>>>>>>>>>>>>>>> F%2Flists.dot.net%2Fmailman%2F
>>>>>>>>>>>>>>>>>>> listinfo%2Fmono-devel-list&dat
>>>>>>>>>>>>>>>>>>> a=01%7C01%7Calkpli%40microsoft
>>>>>>>>>>>>>>>>>>> .com%7C4f1712aba12141771e4008d
>>>>>>>>>>>>>>>>>>> 3f2c9fd2e%7C72f988bf86f141af91
>>>>>>>>>>>>>>>>>>> ab2d7cd011db47%7C1&sdata=b9Lyb
>>>>>>>>>>>>>>>>>>> et0SXWu5pvvxt7qTTZx1Azx7BMcrE%2BmpZbnzq0%3D&reserved=0
>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>> _______________________________________________
>>>>>>>>>>>>> Mono-devel-list mailing list
>>>>>>>>>>>>> Mono-devel-list@lists.dot.net
>>>>>>>>>>>>> http://lists.dot.net/mailman/listinfo/mono-devel-list
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>
>>>>>>
>>>
>
_______________________________________________
Mono-devel-list mailing list
Mono-devel-list@lists.dot.net
http://lists.dot.net/mailman/listinfo/mono-devel-list

Reply via email to