Hi,

I've split the patches up based on their content. Attached.

unused-functions.patch - #if 0 unused functions in dlmalloc.c and strtod.c uninitialized-fixes.patch - make sure variables are initialized with NULL/0 where used without initialization mono-printf-fixes.patch - make sure a format string such as "%s" is used with variable string input printf() style methods explicit-word-size-changes.patch - use GINT_TO_POINTER and such when converting from int32 to word-size declaration-fixes.patch - Fix method declarations that have () instead of (void) and add missing non-static declarations bitwise-branch-checks.patch - be explicit with parenthesis when using bitwise operation as implicit boolean

I've omitted the patch for using write() without checking the result for now. Let me know if you want to move forward with those and how we would want to do it properly.

Thanks,

-- Christian

Attachment: bitwise-branch-checks.patch
Description: Binary data

Attachment: declaration-fixes.patch
Description: Binary data

Attachment: explicit-word-size-changes.patch
Description: Binary data

Attachment: mono-printf-fixes.patch
Description: Binary data

Attachment: uninitialized-fixes.patch
Description: Binary data

Attachment: unused-functions.patch
Description: Binary data



On Aug 4, 2009, at 6:11 AM, Rodrigo Kumpera wrote:

Hi Chistian,

Your patch is full of very different kind of changes, some are simple, others require some thought
about. So let's sort them into smaller and centered patches.

For example, the ones changing printf style calls are mostly ok and should be committed on their own. Then we can see the warnings changes, the io retry stuff and finally what looks like real bugs.

What do you think about it?

Rodrigo


On Fri, Jul 24, 2009 at 2:02 AM, Christian Hergert <ch...@dronelabs.com > wrote:
Round 2,

 * Moved TEMP_FAILURE_RETRY macro to mono/utils/mono-io-portability.h.
 * Removed #ifndef PLATFORM_MACOSX for now.

-- Christian





On Jul 23, 2009, at 8:24 PM, Geoff Norton wrote:

On 23-Jul-09, at 11:02 PM, Christian Hergert wrote:

Hello,

In an effort to get more familiar with some of the code-base, I went through and fixed some of the pesky compiler warnings for the runtime. Attached is a patch for said warnings.

If anyone has suggestions on how to better fix the warnings, please send them my way and I'll adjust the patch as needed.


#1: Having tons of
+#ifndef TEMP_FAILURE_RETRY

is sucky, localize it into mono/utils/somewhere-logical.h and include it around


#2: lots of:
+#ifndef PLATFORM_MACOSX
       FILE *fp;
+#endif

impedes readability (for me) just for 1 platform, not sure its worth it.

As for the rest, it looks sane, but I'll let the runtime guys weigh in.

-g



_______________________________________________
Mono-devel-list mailing list
Mono-devel-list@lists.ximian.com
http://lists.ximian.com/mailman/listinfo/mono-devel-list



_______________________________________________
Mono-devel-list mailing list
Mono-devel-list@lists.ximian.com
http://lists.ximian.com/mailman/listinfo/mono-devel-list

Reply via email to