I can tell you from extensive personal experience with clustered queue
managers in V5.3 that there's a bunch of issues that cropped up.  First, get
to the latest CSD (CSD03) ASAP.  And always upgrade your repository queue
managers first!

<<< A word to the rest of you folks... MQ 5.2 CSD06 is VERY stable and
doesn't have all the cluster problems.  So if you're running clusters, hang
tight and wait for CSD04 of MQ5.3 before moving your clusters forward  >>>

Now, as far as your specific problem, be sure that you don't have any
manually defined CLUSSDR channels pointing at your HP box.  This confuses
the HP QM and will cause it not to act as you would expect in the cluster.
I just worked a similar problem and this was what someone had done.

The other thing to do is issue a REFRESH CLUSTER command on your HP queue
manager and then check the channel status of your channels pointing at the
W2K repository and your HP CLUSRCVR.  Make sure the LSTMSGTI and LSTMSGDA
are recent.  That ensures that the HP is getting refreshed from the
repository.  The 2189 indicates your HP is not talking with either of your
two full repositories.  Again, this could be because of a manually defined
CLUSSDR (mentioned above) or because your W2K repositories for some reason
don't recognize the HP.  Also check the output of DISPLAY CLUSQMGR(*) on the
HP and note what it says.

If none of this proves fruitful, don't wait to call IBM and open a record.
These problems tend to be nasty and convoluted!

Good Luck!

Gary J. Ward
Senior Consulting Engineer
Information Design, Inc.
IBM Premier Business Partner

Date:    Fri, 4 Apr 2003 12:11:20 -0500
From:    "Siegman, Polly" <[EMAIL PROTECTED]>
Subject: Cluster problem

This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.

Content-Type: text/plain

Full Repositories:  Win2000 and AIX 4.3.3

Partial:  AIX 4.3.3 HP 11

All running MQSeries 5.3

I have just added some new cluster qmanagers (AIX) into my existing cluster.
Everything is up and started.  I can see all the qmanagers on the full
repositories, but now the partial repository on the HP is generating a 2189
when I try to put a message to any clustered queue in the environment.  The
clussdr and clusrcvr are running from the HP to the full repo in the Win2000

Everything is communicating fine except the HP.  I cannot start a channel
from the partial repos to the HP, but can everywhere else.  This all was
working fine until I created the new qmanagers on the AIX servers.  I have
tried rebuilding the full repositories and this did not help.

To summarize:

Partial repo on HP is not working properly and I am getting a 2189 when I
try to put a message to a clustered queue.  All of the other full and
partial repos are working fine.

Does HP require something special when running 5.3?

Polly Siegman

Unix System Administrator

PerotSystems @ Owens&Minor

Ph. (804)935-4290

Pager (800)Page-MCI pin #1576939

Instructions for managing your mailing list subscription are provided in
the Listserv General Users Guide available at http://www.lsoft.com
Archive: http://vm.akh-wien.ac.at/MQSeries.archive

Reply via email to