On Fri, Apr 26, 2002 at 02:57:06PM +0200, Ha Nguyen wrote: > Hi all, > > I have nessus 1.2.0 running (correctly) on RH 7.2. nessus-update-plugins > without any options works correctly. But, the following error message > appears when I try nessus-update-plugins with the -i option: > > [root@test211 root]# nessus-update-plugins -i smb_nt_ms02-016.nasl > /usr/local/sbin/nessus-update-plugins: test: /usr/bin/wget -q -O -: binary > opera > tor expected > Error $fetch_cmd or $gzip are not set - abort
There was a bug in the version given with Nessus 1.2.0 -it's fixed in the CVS now. Here's a patch : diff -r1.16 nessus-update-plugins 94c94 < if test -n "$fetch_cmd" ; --- > if [ -n "$fetch_cmd" ]; 108c108 < if test -n "$fetch_cmd" ; --- > if [ -n "$fetch_cmd" ]; 117c117 < if test -n "$fetch_cmd" -a ; --- > if [ -n "$fetch_cmd" ]; 221c221 < if test -n "$fetch_cmd" -a -n "$gzip" ; --- > if [ -n "$fetch_cmd" -a -n "$gzip" ] ;
